lantiq: Tune the XWAY subtarget cflags
authorJohn Crispin <john@openwrt.org>
Fri, 21 Jun 2013 16:54:15 +0000 (16:54 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 21 Jun 2013 16:54:15 +0000 (16:54 +0000)
This patch sets the cflags -mtune=34kc -mdsp only in XWAY subtarget, while the others remain with mtune=mips32r2.
Although the Danube has a Mips 24KEc core performs well with the above cflags.

Signed-off-by: José Vázquez Fernández <ppvazquezfer@gmail.com>
SVN-Revision: 37006

target/linux/lantiq/Makefile
target/linux/lantiq/ase/target.mk
target/linux/lantiq/falcon/target.mk
target/linux/lantiq/svip_be/target.mk
target/linux/lantiq/svip_le/target.mk
target/linux/lantiq/xway/target.mk

index d8c12ed3e59e4552268ffe4d7d049687da0b3f69..25fea540800f90f82a47070b8deb5d9f1b03b9e2 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS=xway ase falcon
 
 LINUX_VERSION:=3.8.13
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+CFLAGS=-Os -pipe -mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC
index a052dd2ce79dae231275c87fccfbdb8235b3c229..f1f0c07eb32d8081a469dc12242da112fe274cd7 100644 (file)
@@ -2,6 +2,7 @@ ARCH:=mips
 SUBTARGET:=ase
 BOARDNAME:=Amazon-SE
 FEATURES:=squashfs atm
+CFLAGS+= -mtune=mips32r2
 
 DEFAULT_PACKAGES+=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl kmod-ltq-dsl-ase ltq-dsl-app
 
index 14ac402473a6f8b50c80c0bdf99ed069948a81c4..b7af20c79c11b1eea47e75703e129e0efb2f8630 100644 (file)
@@ -3,6 +3,7 @@ SUBTARGET:=falcon
 BOARDNAME:=Falcon
 FEATURES:=squashfs
 DEVICE_TYPE:=other
+CFLAGS+= -mtune=mips32r2
 
 DEFAULT_PACKAGES+= kmod-ifxos gpon-base-files kmod-leds-gpio kmod-ledtrig-heartbeat \
        kmod-gpon-optic-drv gpon-optic-drv kmod-gpon-onu-drv gpon-onu-drv \
index 7cdd540590a522485965a0e002e32089648460e9..ef8eeffa43a98223eecbcc568a7c2736fbfcc0c4 100644 (file)
@@ -3,6 +3,7 @@ SUBTARGET:=svip_be
 BOARDNAME:=SVIP Big Endian
 FEATURES:=squashfs
 DEVICE_TYPE:=other
+CFLAGS+= -mtune=mips32r2
 
 DEFAULT_PACKAGES+= uboot-svip hostapd-mini
 
index 2c1ed07a4e06c07c557f6393f43caf5491f3c269..d2ccdbcfe1a61e856b56597cf2eff88632595a03 100644 (file)
@@ -3,6 +3,7 @@ SUBTARGET:=svip_le
 BOARDNAME:=SVIP Little Endian
 FEATURES:=squashfs
 DEVICE_TYPE:=other
+CFLAGS+= -mtune=mips32r2
 
 DEFAULT_PACKAGES+= uboot-svip hostapd-mini
 
index 540de1480114dc1465e5f8c2149ffdff3e82b05f..ffbc4eaefeb5795c2e7936dcb1dcaf8628930ab8 100644 (file)
@@ -2,6 +2,7 @@ ARCH:=mips
 SUBTARGET:=xway
 BOARDNAME:=XWAY
 FEATURES:=squashfs atm mips16
+CFLAGS+= -mtune=34kc -mdsp
 
 DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug