lantiq: Tune the XWAY subtarget cflags
[openwrt/staging/yousong.git] / package / mountd / Makefile
index 87ddef50f85fdd01bfcad15c6cca9c2860855d44..10534ccdf4225e909f8ba769df13d2f5ecda7dff 100644 (file)
@@ -1,15 +1,16 @@
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
 # All rights reserved.
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mountd
 PKG_VERSION:=0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 PKG_MD5SUM:=b77253ee4321d24d200fffc4f7ca3d15
+PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -17,7 +18,7 @@ define Package/mountd
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=OpenWrt automount daemon
-  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +uci +kmod-usb-storage +kmod-fs-autofs4
+  DEPENDS:=@USB_SUPPORT +uci +kmod-usb-storage +kmod-fs-autofs4
   URL:=http://www.openwrt.org
 endef
 
@@ -25,6 +26,10 @@ define Package/mountd/description
   openwrt automount daemon
 endef
 
+define Package/mountd/conffiles
+/etc/config/mountd
+endef
+
 define Build/Compile
        $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(PKG_BUILD_DIR)" \
@@ -35,9 +40,8 @@ endef
 define Package/mountd/install
        $(INSTALL_DIR) $(1)/sbin/ $(1)/etc/config/ $(1)/etc/init.d/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/mountd $(1)/sbin/
-       $(INSTALL_BIN) ./files/mountd.config $(1)/etc/config/mountd
-       $(INSTALL_DATA) ./files/mountd.init $(1)/etc/init.d/mountd
+       $(INSTALL_DATA) ./files/mountd.config $(1)/etc/config/mountd
+       $(INSTALL_BIN) ./files/mountd.init $(1)/etc/init.d/mountd
 endef
 
 $(eval $(call BuildPackage,mountd))
-