malta: restore "be" subtarget from being source-only
[openwrt/staging/yousong.git] / target / linux / bcm53xx / Makefile
index 51b80dbb98efb57929fd2f98957f9089d9903b1a..a98fd3923d1795f4d47a80a2138219ec939dc44e 100644 (file)
@@ -12,19 +12,20 @@ BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
 FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
 
-LINUX_VERSION:=3.14.18
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-KERNELNAME:="zImage dtbs"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage dtbs
 
 DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+       osafeloader oseama otrx \
+       kmod-gpio-button-hotplug \
        kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
 
 $(eval $(call BuildTarget))