malta: restore "be" subtarget from being source-only
[openwrt/staging/yousong.git] / target / linux / bcm53xx / Makefile
index daad42b36938f74bbede5b1b25f0a530fdc194b1..a98fd3923d1795f4d47a80a2138219ec939dc44e 100644 (file)
@@ -13,16 +13,19 @@ FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 
-LINUX_VERSION:=3.14.18
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-KERNELNAME:="zImage dtbs"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig wpad-mini nvram
+DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+       osafeloader oseama otrx \
+       kmod-gpio-button-hotplug \
+       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
 
 $(eval $(call BuildTarget))