update kernel versions
[openwrt/staging/yousong.git] / target / linux / ixp4xx / Makefile
index f68f62bc7de98353f331198d74f6ffee4002a416..f65dc91d3529a520eeacbac5017d6383bf7f702d 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=armeb
 BOARD:=ixp4xx
-BOARDNAME:=Intel XScale IXP4xx
+BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
+SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.21.6
+LINUX_VERSION:=2.6.32.16
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
+DEFAULT_PACKAGES += ixp4xx-microcode fconfig
 
 $(eval $(call BuildTarget))