ixp4xx/cns3xxx: add rfkill module support
authorJohn Crispin <john@openwrt.org>
Wed, 17 Oct 2012 22:46:16 +0000 (22:46 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 17 Oct 2012 22:46:16 +0000 (22:46 +0000)
Both ixp4xx and cns3xxx targets support RFKILL in the kernel.
Also add a RFKILL_GPIO default for kernel config

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
SVN-Revision: 33831

package/kernel/modules/001-depends.mk
package/kernel/modules/other.mk

index 6c493018df2fd926d43c5442afb25da40e20c648..e0af73570516822a658d60b21d8e7acd487eab31 100644 (file)
@@ -24,11 +24,11 @@ endef
 
 
 define SetDepends/rfkill
-  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini)
+  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx)
 endef
 
 define AddDepends/rfkill
-  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
+  DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_cns3xxx||TARGET_ixp4xx):kmod-rfkill $(1)
 endef
 
 
index 57614387a782060c3ac13059bd137137bdca6af1..f370f65129b0360a99669b225ddd13bcefb73c95 100644 (file)
@@ -363,7 +363,8 @@ define KernelPackage/rfkill
   KCONFIG:= \
     CONFIG_RFKILL \
     CONFIG_RFKILL_INPUT=y \
-    CONFIG_RFKILL_LEDS=y
+    CONFIG_RFKILL_LEDS=y \
+    CONFIG_RFKILL_GPIO=y
   FILES:= \
     $(LINUX_DIR)/net/rfkill/rfkill.ko
   AUTOLOAD:=$(call AutoLoad,20,rfkill)