ar71xx: create profile and build image for the OpenMesh OM5P-AC board
authorJohn Crispin <john@openwrt.org>
Sat, 9 Apr 2016 10:26:11 +0000 (10:26 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 9 Apr 2016 10:26:11 +0000 (10:26 +0000)
Signed-off-by: Sven Eckelmann <sven.eckelmann@open-mesh.com>
SVN-Revision: 49148

target/linux/ar71xx/generic/profiles/openmesh.mk
target/linux/ar71xx/image/Makefile

index 1c51e93a92ec2ee09bd08bca4237218eb6665a60..0873ac53066f0fef7d8ebae36b6d201eb7136db1 100644 (file)
@@ -27,6 +27,17 @@ endef
 
 $(eval $(call Profile,OM5P))
 
+define Profile/OM5PAC
+       NAME:=OpenMesh OM5P-AC
+       PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
+endef
+
+define Profile/OM5PAC/Description
+       Package set optimized for the OpenMesh OM5P-AC.
+endef
+
+$(eval $(call Profile,OM5PAC))
+
 define Profile/MR600
         NAME:=OpenMesh MR600
         PACKAGES:=kmod-ath9k om-watchdog
index 595fba2deb712d2abbe2b93fe9784b3f2e717ff0..eb7a7f0330922082cccd144da18b79e261a97aa0 100644 (file)
@@ -2470,6 +2470,7 @@ $(eval $(call SingleProfile,Netgear,64kraw,WPN824N,wpn824n,WPN824N,ttyS0,115200,
 
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,OM2P,om2p,,,,OM2P))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,OM5P,om5p,,,,OM5P))
+$(eval $(call SingleProfile,OpenMesh,squashfs-only,OM5PAC,om5pac,,,,OM5PAC))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,MR600,mr600,,,,MR600))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,MR900,mr900,,,,MR900))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,MR1750,mr1750,,,,MR1750))
@@ -2518,7 +2519,7 @@ $(eval $(call MultiProfile,AP147,AP147_010))
 $(eval $(call MultiProfile,AP152,AP152_16M))
 $(eval $(call MultiProfile,DIR615IX,DIR615I1 DIR615I3))
 $(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT EWDORIN16M))
-$(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600 MR900 MR1750))
+$(eval $(call MultiProfile,OPENMESH,OM2P OM5P OM5PAC MR600 MR900 MR1750))
 $(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))
 $(eval $(call MultiProfile,TUBE2H,TUBE2H8M TUBE2H16M))
 $(eval $(call MultiProfile,WNR612V2,REALWNR612V2 N150R))