kernel: fix x86 objdump invocation on 3.14 and 3.18
authorFelix Fietkau <nbd@openwrt.org>
Mon, 8 Dec 2014 10:04:39 +0000 (10:04 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 8 Dec 2014 10:04:39 +0000 (10:04 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 43557

target/linux/generic/patches-3.14/270-x86_objdump_command.patch [new file with mode: 0644]
target/linux/generic/patches-3.18/270-x86_objdump_command.patch [new file with mode: 0644]

diff --git a/target/linux/generic/patches-3.14/270-x86_objdump_command.patch b/target/linux/generic/patches-3.14/270-x86_objdump_command.patch
new file mode 100644 (file)
index 0000000..1506269
--- /dev/null
@@ -0,0 +1,16 @@
+Use the cross toolchain objdump command instead of assuming that the host
+toolchain has it.
+
+Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+
+--- a/arch/x86/boot/compressed/Makefile
++++ b/arch/x86/boot/compressed/Makefile
+@@ -75,7 +75,7 @@ suffix-$(CONFIG_KERNEL_XZ)   := xz
+ suffix-$(CONFIG_KERNEL_LZO)   := lzo
+ suffix-$(CONFIG_KERNEL_LZ4)   := lz4
+-RUN_SIZE = $(shell objdump -h vmlinux | \
++RUN_SIZE = $(shell $(OBJDUMP) -h vmlinux | \
+            perl $(srctree)/arch/x86/tools/calc_run_size.pl)
+ quiet_cmd_mkpiggy = MKPIGGY $@
+       cmd_mkpiggy = $(obj)/mkpiggy $< $(RUN_SIZE) > $@ || ( rm -f $@ ; false )
diff --git a/target/linux/generic/patches-3.18/270-x86_objdump_command.patch b/target/linux/generic/patches-3.18/270-x86_objdump_command.patch
new file mode 100644 (file)
index 0000000..7d4170e
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/x86/boot/compressed/Makefile
++++ b/arch/x86/boot/compressed/Makefile
+@@ -76,7 +76,7 @@ suffix-$(CONFIG_KERNEL_XZ)   := xz
+ suffix-$(CONFIG_KERNEL_LZO)   := lzo
+ suffix-$(CONFIG_KERNEL_LZ4)   := lz4
+-RUN_SIZE = $(shell objdump -h vmlinux | \
++RUN_SIZE = $(shell $(OBJDUMP) -h vmlinux | \
+            perl $(srctree)/arch/x86/tools/calc_run_size.pl)
+ quiet_cmd_mkpiggy = MKPIGGY $@
+       cmd_mkpiggy = $(obj)/mkpiggy $< $(RUN_SIZE) > $@ || ( rm -f $@ ; false )