add tools/cmake
authorFelix Fietkau <nbd@openwrt.org>
Mon, 31 Jan 2011 20:15:57 +0000 (20:15 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 31 Jan 2011 20:15:57 +0000 (20:15 +0000)
SVN-Revision: 25264

tools/Makefile
tools/cmake/Makefile [new file with mode: 0644]

index d8e7bfd8ee85e5fac428456fc56d9b1000540bea..cefb008a42055793f9eed7729e682382fd36b0c2 100644 (file)
@@ -17,7 +17,7 @@ endif
 tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
-tools-y += mm-macros xorg-macros missing-macros xz
+tools-y += mm-macros xorg-macros missing-macros xz cmake
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_TARGET_x86) += qemu
 ifneq ($(CONFIG_TARGET_ar71xx),)
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
new file mode 100644 (file)
index 0000000..dbc2a7e
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=cmake
+PKG_VERSION:=2.8.3
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.cmake.org/files/v2.8/
+PKG_MD5SUM:=a76a44b93acf5e3badda9de111385921
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))