ARC: use -mcpu=XXX instead of obsolete -mXXX
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>
Wed, 8 Feb 2017 17:52:08 +0000 (20:52 +0300)
committerJohn Crispin <john@phrozen.org>
Sat, 11 Feb 2017 05:53:25 +0000 (06:53 +0100)
-mXXX option is deprecated already in arc-2016.03 toolchain
and removed completely starting from arc-2016.09.

Direct replacement is -mcpu=XXX which is already supported by
arc-2016.03 used today in Lede.

With that change we'll be ready for ARC toolchain update still
keeping everything working with current tools.

Signed-off-by: Alexey Brodkin <Alexey.Brodkin@synopsys.com>
Cc: John Crispin <john@phrozen.org>
include/target.mk

index 30994485e183c16d052614aa00b5046e58e5e9ae..5490d4882f4c4a869ab4444f8afb408dfd6b4984 100644 (file)
@@ -215,8 +215,8 @@ ifeq ($(DUMP),1)
   ifeq ($(ARCH),arc)
     CPU_TYPE ?= arc700
     CPU_CFLAGS += -matomic
-    CPU_CFLAGS_arc700 = -marc700
-    CPU_CFLAGS_archs = -marchs
+    CPU_CFLAGS_arc700 = -mcpu=arc700
+    CPU_CFLAGS_archs = -mcpu=archs
   endif
   DEFAULT_CFLAGS=$(strip $(CPU_CFLAGS) $(CPU_CFLAGS_$(CPU_TYPE)) $(CPU_CFLAGS_$(CPU_SUBTYPE)))