kernel: enable kernel support for ALSA midi
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Sat, 14 Jul 2012 20:10:57 +0000 (20:10 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Sat, 14 Jul 2012 20:10:57 +0000 (20:10 +0000)
Here is a newer version of the patch:

Enable the real ALSA midi interface (seq) in the kernel. The existing
rawmidi interface is still present. This allows for the alsa midi
utilities to work.

Signed-off-by: Adam Goode <adam@spicenitz.org>
[b_tsiligiannis: replaced $(LINUX_KMOD_SUFFIX) with .ko]
Signed-off-by: Vasilis Tsiligiannis <b_tsiligiannis@silverton.gr>
SVN-Revision: 32712

package/kernel/modules/sound.mk

index 2d0a987b644f2aee33fcf875c9673586acd05b07..d014f36f0d62cd873003835ef609e2caf3342128 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -108,6 +108,23 @@ endef
 $(eval $(call KernelPackage,ac97))
 
 
+define KernelPackage/sound-seq
+  TITLE:=Sequencer support
+  FILES:= \
+       $(LINUX_DIR)/sound/core/seq/snd-seq.ko \
+       $(LINUX_DIR)/sound/core/seq/snd-seq-midi-event.ko \
+       $(LINUX_DIR)/sound/core/seq/snd-seq-midi.ko
+  AUTOLOAD:=$(call AutoLoad,35,snd-seq snd-seq-midi-event snd-seq-midi)
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-seq/description
+ Kernel modules for sequencer support
+endef
+
+$(eval $(call KernelPackage,sound-seq))
+
+
 define KernelPackage/sound-i8x0
   TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
   DEPENDS:=+kmod-ac97