package/kernel: create package for the RT305x dwc_otg driver
authorGabor Juhos <juhosg@openwrt.org>
Mon, 15 Aug 2011 14:11:57 +0000 (14:11 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 15 Aug 2011 14:11:57 +0000 (14:11 +0000)
Based on a patch by Layne Edwards <ledwards76@gmail.com>

SVN-Revision: 27998

package/kernel/modules/usb.mk

index 9e98a102fc1622ce9f083ad1f3b6ad2bc12b4d9b..92771546636422a3cfb8e2694c84cd614fe601b3 100644 (file)
@@ -947,3 +947,22 @@ endef
 
 $(eval $(call KernelPackage,usb-phidget))
 
+define KernelPackage/usb-rt305x-dwc_otg
+  TITLE:=RT305X USB controller driver
+  DEPENDS:=@TARGET_ramips_rt305x
+  KCONFIG:= \
+       CONFIG_DWC_OTG \
+       CONFIG_DWC_OTG_HOST_ONLY=y \
+       CONFIG_DWC_OTG_DEVICE_ONLY=n \
+       CONFIG_DWC_OTG_DEBUG=n
+  FILES:=$(LINUX_DIR)/drivers/usb/dwc_otg/dwc_otg.ko
+  AUTOLOAD:=$(call AutoLoad,54,dwc_otg)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-rt305x-dwc_otg/description
+  This driver provides USB Device Controller support for the
+  Synopsys DesignWare USB OTG Core used in the Ralink RT305X SoCs.
+endef
+
+$(eval $(call KernelPackage,usb-rt305x-dwc_otg))