add default command for dummy targets
authorFelix Fietkau <nbd@openwrt.org>
Sat, 28 Jul 2007 14:36:21 +0000 (14:36 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 28 Jul 2007 14:36:21 +0000 (14:36 +0000)
SVN-Revision: 8209

include/subdir.mk

index 407f8a81db5599f2d96fe455d86fcfe272b68c3d..b2bc04b357e7716e4ba541870e94623c0e98cd6c 100644 (file)
@@ -39,7 +39,7 @@ define subdir
        )
   )
   $(foreach target,$(SUBTARGETS),
-    $(call warn_eval,$(1),t,T,$(1)/$(target): $($(1)/) $(foreach bd,$(if $($(1)/builddirs-$(target)),$($(1)/builddirs-$(target)),$($(1)/builddirs)),$(1)/$(bd)/$(target)))
+    $(call warn_eval,$(1),t,T,$(1)/$(target): $($(1)/) $(foreach bd,$(if $($(1)/builddirs-$(target)),$($(1)/builddirs-$(target)),$($(1)/builddirs)),$(1)/$(bd)/$(target)) ;)
   )
 endef