remove uneeded flags, fix shared lib install
authorNicolas Thill <nico@openwrt.org>
Sat, 22 Sep 2007 04:22:30 +0000 (04:22 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 22 Sep 2007 04:22:30 +0000 (04:22 +0000)
SVN-Revision: 8943

package/linux-atm/Makefile

index ecadb3d6ad20db1b5647b123e6ac7dcc6a082aaf..ffac08b251548dda8b87408f041c31049b711feb 100644 (file)
@@ -47,10 +47,8 @@ define Build/Configure
        touch $(PKG_BUILD_DIR)/stamp-h.in
 endef
 
-TARGET_CFLAGS := -I$(PKG_BUILD_DIR)/src/include $(TARGET_CFLAGS)
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
@@ -71,7 +69,7 @@ endef
 
 define Package/linux-atm/install
        $(INSTALL_DIR) $(1)/usr/lib
-       cp -f $(PKG_INSTALL_DIR)/usr/lib/libatm.so.1 $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libatm.so.* $(1)/usr/lib/
 endef
 
 define Package/atm-tools/install