add crypto-pcompress
authorJohn Crispin <john@openwrt.org>
Sat, 15 Dec 2012 01:59:29 +0000 (01:59 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 15 Dec 2012 01:59:29 +0000 (01:59 +0000)
SVN-Revision: 34685

package/kernel/modules/crypto.mk

index 383f9f318cfa0ee16571bc6eb5646f18dca7058a..d8242952b9485c317d2f4e0ff90b75ed6959d278 100644 (file)
@@ -60,6 +60,17 @@ define KernelPackage/crypto-manager
 endef
 $(eval $(call KernelPackage,crypto-manager))
 
+define KernelPackage/crypto-pcompress
+  TITLE:=CryptoAPI Partial (de)compression operations
+  KCONFIG:= \
+       CONFIG_CRYPTO_PCOMP=y \
+       CONFIG_CRYPTO_PCOMP2
+  FILES:=$(LINUX_DIR)/crypto/pcompress.ko
+  AUTOLOAD:=$(call AutoLoad,09,pcompress)
+  $(call AddDepends/crypto)
+endef
+$(eval $(call KernelPackage,crypto-pcompress))
+
 define KernelPackage/crypto-user
   TITLE:=CryptoAPI userspace interface
   DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager