Add sch_fq and sch_pie to the kmod-sched package.
authorSteven Barth <cyrus@openwrt.org>
Thu, 4 Jun 2015 05:44:44 +0000 (05:44 +0000)
committerSteven Barth <cyrus@openwrt.org>
Thu, 4 Jun 2015 05:44:44 +0000 (05:44 +0000)
These are two new packet schedulers introduced in Linux 3.12 and 3.14
respectively. sch_fq is a perfect fairness queueing scheduler that also
adds pacing on host TCP flows, and sch_pie is an AQM.

Having them available in kmod-sched makes it easier for people to test
these new queueing schemes.

Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
SVN-Revision: 45885

package/kernel/linux/modules/netsupport.mk

index 4483581bf4bf0f41312bc24c3b36d13c0e4e18bd..adfdace3608ec1ba18c32137dce06e4fd3eac895 100644 (file)
@@ -802,6 +802,8 @@ define KernelPackage/sched
        CONFIG_NET_SCH_TBF \
        CONFIG_NET_SCH_SFQ \
        CONFIG_NET_SCH_TEQL \
+       CONFIG_NET_SCH_FQ \
+       CONFIG_NET_SCH_PIE \
        CONFIG_NET_CLS_BASIC \
        CONFIG_NET_ACT_POLICE \
        CONFIG_NET_ACT_IPT \