x86_64: use default block2mtd timeout of 5s
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Oct 2014 17:46:37 +0000 (17:46 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Oct 2014 17:46:37 +0000 (17:46 +0000)
If the underlying block device is a USB device it might require some
time to settle, observed when booting a squashfs image from sd card
on an Alix APU board.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 42966

target/linux/x86_64/image/Makefile

index aacdab0ff685be82d5f8210ea6337d672a464cda..e8d9ac11587dc5961422a3d9cf5a619ee6b6818d 100644 (file)
@@ -55,15 +55,15 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
   endef
 
   define Image/cmdline/jffs2-64k
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
+    block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
   endef
 
   define Image/cmdline/jffs2-128k
-    block2mtd.block2mtd=$(ROOTPART),131072,rootfs root=/dev/mtdblock0 rootfstype=jffs2 rootwait
+    block2mtd.block2mtd=$(ROOTPART),131072,rootfs,5 root=/dev/mtdblock0 rootfstype=jffs2 rootwait
   endef
 
   define Image/cmdline/squashfs
-    block2mtd.block2mtd=$(ROOTPART),65536,rootfs root=/dev/mtdblock0 rootfstype=squashfs rootwait
+    block2mtd.block2mtd=$(ROOTPART),65536,rootfs,5 root=/dev/mtdblock0 rootfstype=squashfs rootwait
   endef
 
   define Image/Build/grub2