move arch specific base-files install call to the end of the generic one - fixes...
authorFelix Fietkau <nbd@openwrt.org>
Wed, 4 Oct 2006 20:03:26 +0000 (20:03 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 4 Oct 2006 20:03:26 +0000 (20:03 +0000)
SVN-Revision: 4914

openwrt/package/base-files/Makefile

index 1e234c65a370c5064afcea59c4a9e248e8853dfb..9f6da3bc7cd7933c28df3566363e436a4db16f45 100644 (file)
@@ -142,7 +142,6 @@ define Package/base-files$(TARGET)/install-brcm
 endef
 
 define Package/base-files$(TARGET)/install
-  $(call Package/base-files$(TARGET)/install-$(BOARD),$(1))
        $(CP) ./default/* $(1)/
        if [ -d $(BOARD)-$(KERNEL) ]; then \
                $(CP) $(BOARD)-$(KERNEL)/* $(1)/; \
@@ -164,6 +163,7 @@ define Package/base-files$(TARGET)/install
        rm -f $(1)/var
        ln -sf /tmp $(1)/var
        mkdir -p $(1)/etc
+$(call Package/base-files$(TARGET)/install-$(BOARD),$(1))
 endef
 
 define Package/libgcc/install