ar71xx: separate DIR-615 rev. C1 support from the TEW-632 (based on the patch from...
authorGabor Juhos <juhosg@openwrt.org>
Fri, 18 Dec 2009 12:57:01 +0000 (12:57 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 18 Dec 2009 12:57:01 +0000 (12:57 +0000)
SVN-Revision: 18818

13 files changed:
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/preinit.arch
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-2.6.30
target/linux/ar71xx/config-2.6.31
target/linux/ar71xx/config-2.6.32
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-dir-615-c1.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/ar71xx.h
target/linux/ar71xx/image/Makefile

index d3d88757008c038659f518acb74da42e13c3d437..a74df07ce3e16cf04bb6c37b2d7d51730e5dfe7a 100755 (executable)
@@ -42,6 +42,9 @@ get_status_led() {
        bullet-m | rocket-m | nano-m)
                status_led="ubnt:green:link4"
                ;;
+       dir-615-c1)
+               status_led="dir-615c1:green:status"
+               ;;
        dir-825-b1)
                status_led="dir825b1:orange:power"
                ;;
index a6af7e117aaaeb037a8a39d2d9fc5aeb5b89a336..637aa5fc50e59693550eef2ff3c1fb2020eba83e 100644 (file)
@@ -32,6 +32,10 @@ preinit_set_mac_address() {
                tew-632brp)
                        fetch_mac_from_mtd config lan_mac wan_mac
                        ;;
+               dir-615-c1)
+                       fetch_mac_from_mtd config lan_mac wan_mac
+                       echo 1 > /sys/class/leds/dir-615-c1:green:wancpu/brightness
+                       ;;
                wrt160nl)
                        fetch_mac_from_mtd nvram lan_hwaddr wan_hwaddr
                        ;;
index 9eea471b3225ffdadeed2fe42cd553d1d0a778a1..e73bb7f64f742d3e19c4a5a85b1c0c62764db79a 100755 (executable)
@@ -70,6 +70,9 @@ ar71xx_board_name() {
        *TL-WR1043ND)
                name="tl-wr1043nd"
                ;;
+       *"DIR-615 rev. C1")
+               name="dir-615-c1"
+               ;;
        *TL-WR741ND)
                name="tl-wr741nd"
                ;;
index 728019969b49bc37e8a33682bd8b39a2a7022c76..629e42c304d743fd550e830105910babbbb9fc24 100755 (executable)
@@ -68,7 +68,7 @@ platform_check_image() {
        [ "$ARGC" -gt 1 ] && return 1
 
        case "$board" in
-       ap83 | dir-825-b1 | mzk-w04nu | mzk-w300nh | tew-632brp | wrt-400n | bullet-m | nano-m | rocket-m)
+       ap83 | dir-615-c1 | dir-825-b1 | mzk-w04nu | mzk-w300nh | tew-632brp | wrt-400n | bullet-m | nano-m | rocket-m)
                [ "$magic" != "2705" ] && {
                        echo "Invalid image type."
                        return 1
index 842424de60c05ab1ae6d0a9bb085434f0577f417..c957cf0a591600e3d99f705a86e8de2d4fa9cecc 100644 (file)
@@ -7,6 +7,7 @@ CONFIG_AR71XX_DEV_M25P80=y
 CONFIG_AR71XX_MACH_AP81=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
+CONFIG_AR71XX_MACH_DIR_615_C1=y
 CONFIG_AR71XX_MACH_DIR_825_B1=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_MZK_W04NU=y
index b506467e50be62fa56d31427357dbed066d577bd..dd508c48b96b9170ea94640c79d457edf0aaf060 100644 (file)
@@ -9,6 +9,7 @@ CONFIG_AR71XX_DEV_M25P80=y
 CONFIG_AR71XX_MACH_AP81=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
+CONFIG_AR71XX_MACH_DIR_615_C1=y
 CONFIG_AR71XX_MACH_DIR_825_B1=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_MZK_W04NU=y
index 70cd31f482fc48d23e13a4f00d13929dceda7238..2c952c776e9a68c7401e330b74a370564c6d5e03 100644 (file)
@@ -9,6 +9,7 @@ CONFIG_AR71XX_DEV_M25P80=y
 CONFIG_AR71XX_MACH_AP81=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
+CONFIG_AR71XX_MACH_DIR_615_C1=y
 CONFIG_AR71XX_MACH_DIR_825_B1=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_MZK_W04NU=y
index 6ab6eefa9cfb5c658f88261649f7a84be52821e9..95ca96a651a4070d92f00a3e8ebb65d3023b5e97 100644 (file)
@@ -11,6 +11,11 @@ config AR71XX_MACH_AP83
        bool "Atheros AP83 board support"
        default y
 
+config AR71XX_MACH_DIR_615_C1
+       bool "D-Link DIR-615 rev. C1 support"
+       select AR71XX_DEV_M25P80
+       default y
+
 config AR71XX_MACH_DIR_825_B1
        bool "D-Link DIR-825 rev. B1 board support"
        select AR71XX_DEV_M25P80
index 1b9bdafd82fce197ae725b6b3241162c6b288d8f..6de785dc820e4b0b283a710a1f662ec18d8086c3 100644 (file)
@@ -18,6 +18,7 @@ obj-$(CONFIG_AR71XX_DEV_M25P80)               += dev-m25p80.o
 obj-$(CONFIG_AR71XX_MACH_AP81)         += mach-ap81.o
 obj-$(CONFIG_AR71XX_MACH_AP83)         += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
+obj-$(CONFIG_AR71XX_MACH_DIR_615_C1)   += mach-dir-615-c1.o
 obj-$(CONFIG_AR71XX_MACH_DIR_825_B1)   += mach-dir-825-b1.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
 obj-$(CONFIG_AR71XX_MACH_MZK_W04NU)    += mach-mzk-w04nu.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-dir-615-c1.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-dir-615-c1.c
new file mode 100644 (file)
index 0000000..1b90105
--- /dev/null
@@ -0,0 +1,154 @@
+/*
+ *  D-Link DIR-615 rev C1 board support
+ *
+ *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/input.h>
+
+#include <asm/mips_machine.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "devices.h"
+#include "dev-m25p80.h"
+
+#define DIR_615C1_GPIO_LED_ORANGE_STATUS 1     /* ORANGE:STATUS:TRICOLOR */
+#define DIR_615C1_GPIO_LED_BLUE_WPS    3       /* BLUE:WPS */
+#define DIR_615C1_GPIO_LED_GREEN_WAN   4       /* GREEN:WAN:TRICOLOR */
+#define DIR_615C1_GPIO_LED_GREEN_WANCPU        5       /* GREEN:WAN:CPU:TRICOLOR */
+#define DIR_615C1_GPIO_LED_GREEN_WLAN  6       /* GREEN:WLAN */
+#define DIR_615C1_GPIO_LED_GREEN_STATUS        14      /* GREEN:STATUS:TRICOLOR */
+#define DIR_615C1_GPIO_LED_ORANGE_WAN  15      /* ORANGE:WAN:TRICOLOR */
+
+/* buttons may need refinement */
+
+#define DIR_615C1_GPIO_BTN_WPS         12
+#define DIR_615C1_GPIO_BTN_RESET       21
+
+#define DIR_615C1_BUTTONS_POLL_INTERVAL        20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition dir_615c1_partitions[] = {
+       {
+               .name           = "u-boot",
+               .offset         = 0,
+               .size           = 0x020000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "config",
+               .offset         = 0x020000,
+               .size           = 0x010000,
+       } , {
+               .name           = "kernel",
+               .offset         = 0x030000,
+               .size           = 0x0d0000,
+       } , {
+               .name           = "rootfs",
+               .offset         = 0x100000,
+               .size           = 0x2f0000,
+       } , {
+               .name           = "art",
+               .offset         = 0x3f0000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "firmware",
+               .offset         = 0x030000,
+               .size           = 0x3c0000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data dir_615c1_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+        .parts          = dir_615c1_partitions,
+        .nr_parts       = ARRAY_SIZE(dir_615c1_partitions),
+#endif
+};
+
+static struct gpio_led dir_615c1_leds_gpio[] __initdata = {
+       {
+               .name           = "dir-615c1:orange:status",
+               .gpio           = DIR_615C1_GPIO_LED_ORANGE_STATUS,
+               .active_low     = 1,
+       }, {
+               .name           = "dir-615c1:blue:wps",
+               .gpio           = DIR_615C1_GPIO_LED_BLUE_WPS,
+               .active_low     = 1,
+       }, {
+               .name           = "dir-615c1:green:wan",
+               .gpio           = DIR_615C1_GPIO_LED_GREEN_WAN,
+               .active_low     = 1,
+       }, {
+               .name           = "dir-615c1:green:wancpu",
+               .gpio           = DIR_615C1_GPIO_LED_GREEN_WANCPU,
+               .active_low     = 1,
+        }, {
+               .name           = "dir-615c1:green:wlan",
+               .gpio           = DIR_615C1_GPIO_LED_GREEN_WLAN,
+               .active_low     = 1,
+        }, {
+               .name           = "dir-615c1:green:status",
+               .gpio           = DIR_615C1_GPIO_LED_GREEN_STATUS,
+               .active_low     = 1,
+       }, {
+               .name           = "dir-615c1:orange:wan",
+               .gpio           = DIR_615C1_GPIO_LED_ORANGE_WAN,
+               .active_low     = 1,
+       }
+
+};
+
+static struct gpio_button dir_615c1_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = BTN_0,
+               .threshold      = 5,
+               .gpio           = DIR_615C1_GPIO_BTN_RESET,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = BTN_1,
+               .threshold      = 5,
+               .gpio           = DIR_615C1_GPIO_BTN_WPS,
+       }
+};
+
+static void __init dir_615c1_setup(void)
+{
+       ar71xx_add_device_mdio(0x0);
+
+       ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+       ar71xx_eth0_data.phy_mask = 0xf;
+       ar71xx_eth0_data.speed = SPEED_100;
+       ar71xx_eth0_data.duplex = DUPLEX_FULL;
+
+       ar71xx_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+       ar71xx_eth1_data.phy_mask = 0x10;
+
+       ar71xx_add_device_eth(0);
+       ar71xx_add_device_eth(1);
+
+       ar71xx_add_device_m25p80(&dir_615c1_flash_data);
+
+       ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(dir_615c1_leds_gpio),
+                                       dir_615c1_leds_gpio);
+
+       ar71xx_add_device_gpio_buttons(-1, DIR_615C1_BUTTONS_POLL_INTERVAL,
+                                       ARRAY_SIZE(dir_615c1_gpio_buttons),
+                                       dir_615c1_gpio_buttons);
+
+       ar91xx_add_device_wmac();
+}
+
+MIPS_MACHINE(AR71XX_MACH_DIR_615_C1, "D-Link DIR-615 rev. C1", dir_615c1_setup);
index b0a51cfb5703de20fe86982bf945255d9f6dc55e..283aff6a7bdc6952bcb9f56fe935af2599e3e8f0 100644 (file)
@@ -64,6 +64,9 @@ static struct board_rec boards[] __initdata = {
        }, {
                .name           = "TEW-632BRP",
                .mach_type      = AR71XX_MACH_TEW_632BRP,
+       }, {
+               .name           = "DIR-615-C1",
+               .mach_type      = AR71XX_MACH_DIR_615_C1,
        }, {
                .name           = "TL-WR741ND",
                .mach_type      = AR71XX_MACH_TL_WR741ND,
index e68276698d81c097d0c2a739cf15c495b2ab7a2b..6526e357c7dc4050d1d563416ed9410c9c677838 100644 (file)
@@ -137,6 +137,7 @@ enum ar71xx_mach_type {
        AR71XX_MACH_MZK_W04NU,  /* Planex MZK-W04NU */
        AR71XX_MACH_MZK_W300NH, /* Planex MZK-W300NH */
        AR71XX_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
+       AR71XX_MACH_DIR_615_C1, /* D-Link DIR-615 rev. C1 */
        AR71XX_MACH_TL_WR741ND, /* TP-LINK TL-WR741ND */
        AR71XX_MACH_TL_WR941ND, /* TP-LINK TL-WR941ND */
        AR71XX_MACH_TL_WR1043ND, /* TP-LINK TL-WR1041ND */
index 6a04bf24f82c3d23e6d644d20de111c95f75cb86..051f0a3f29540ddc79601f056e7d06b34974d74a 100644 (file)
@@ -402,7 +402,7 @@ define Image/Build/Profile/WP543
 endef
 
 define Image/Build/Profile/DIR615C1
-       $(call Image/Build/Template/Cameo/$(1),dir-615c1,board=TEW-632BRP,"AP81-AR9130-RT-070614-02")
+       $(call Image/Build/Template/Cameo/$(1),dir-615-c1,board=DIR-615-C1,"AP81-AR9130-RT-070614-02")
 endef
 
 define Image/Build/Profile/TEW632BRP