targets: add kernel image dependencies on device tree files
authorFelix Fietkau <nbd@openwrt.org>
Wed, 6 Jan 2016 18:39:06 +0000 (18:39 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 6 Jan 2016 18:39:06 +0000 (18:39 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48146

target/linux/arc770/image/Makefile
target/linux/bcm53xx/image/Makefile
target/linux/brcm63xx/image/Makefile
target/linux/ipq806x/image/Makefile
target/linux/kirkwood/image/Makefile
target/linux/ramips/image/Makefile

index c033102d51f0ff872ae95b985f52f25f30a56a67..6b9c5e4524b65b1e85e6695eee846caa251944b2 100644 (file)
@@ -15,6 +15,7 @@ endef
 # Shared device definition: applies to every defined device
 define Device/Default
   PROFILES = Default $$(DEVICE_PROFILE)
+  KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
   KERNEL_SUFFIX := .elf
   KERNEL_INITRAMFS := kernel-bin | patch-dtb
   KERNEL_INITRAMFS_NAME = $$(KERNEL_NAME)-initramfs.elf
index c9987dddc78aedadbe78ea45215418073825ea1f..d9d4a80fa1098781799c318078bf7fe2356611ca 100644 (file)
@@ -67,6 +67,7 @@ define Device/Default
   # extract the full dtb name based on the device info
   DT := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
   KERNEL := kernel-bin | append-dtb | lzma-d16
+  KERNEL_DEPENDS = $$(wildcard $(KDIR)/$$(DT).dts)
   FILESYSTEMS := squashfs
   KERNEL_NAME := zImage
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
index 53e4c217e8fd5ac2cf83485fc209a3f524e16830..81a9dc70cc816fe60ab5a03cb2f48c46b3e6c9bc 100644 (file)
@@ -168,6 +168,7 @@ endef
 # Shared device definition: applies to every defined device
 define Device/Default
   PROFILES = Default $$(DEVICE_PROFILE)
+  KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
   KERNEL_INITRAMFS_IMAGE = $$(KERNEL_INITRAMFS_PREFIX).elf
   DEVICE_PROFILE :=
   DEVICE_DTS :=
index 14cf442f43fd9c3793ed290531c49bc7c2cdfaf2..58c4e1e8726f73c74b84b94f145e911b43d3e3cf 100644 (file)
@@ -42,6 +42,7 @@ endef
 
 define Device/Default
        PROFILES := Default
+       KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_INITRAMFS_PREFIX := $$(IMG_PREFIX)-$(1)-initramfs
        DEVICE_DTS :=
        KERNEL_PREFIX := $$(IMAGE_PREFIX)
index 3fc84aa7564747ecdd5d1fcbbdba76c13c401818..24cb31702d575dbda90cf6cadd9880d2dd923439 100644 (file)
@@ -15,6 +15,7 @@ KERNEL_LOADADDR:=0x8000
 TARGET_DEVICES = linksys-audi linksys-viper
 
 define Device/Default
+  KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
   KERNEL := kernel-bin | append-dtb | uImage none
   KERNEL_NAME := zImage
 endef
index e4cbdb6e4f4b0a83dd46c467e60f2976d1f46ad0..05d979573a0cd62a4ba02b0175ce327c9e4586d2 100644 (file)
@@ -32,6 +32,7 @@ KERNEL_LOADADDR := $(loadaddr-y)
 
 KERNEL_DTB = kernel-bin | patch-dtb | lzma
 define Device/Default
+  KERNEL_DEPENDS = $$(wildcard ../dts/$$(DTS).dts)
   KERNEL := $(KERNEL_DTB) | uImage lzma
   IMAGES := sysupgrade.bin
   IMAGE_SIZE := $(ralink_default_fw_size_8M)