package/kernel: add kmod-lib-lzo
authorNicolas Thill <nico@openwrt.org>
Fri, 28 Oct 2011 13:11:12 +0000 (13:11 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 28 Oct 2011 13:11:12 +0000 (13:11 +0000)
SVN-Revision: 28654

package/kernel/modules/lib.mk

index 4b9eed45e2fdd7fd3ec05bd5d316f6f238471a82..6e805568da52dd3bca5c95a466e39bcf5969485e 100644 (file)
@@ -83,6 +83,25 @@ endef
 $(eval $(call KernelPackage,libcrc32c))
 
 
+define KernelPackage/lib-lzo
+  SUBMENU:=$(LIB_MENU)
+  TITLE:=LZO library support
+  KCONFIG:= \
+       CONFIG_LZO_COMPRESS \
+       CONFIG_LZO_DECOMPRESS
+  FILES:= \
+       $(LINUX_DIR)/lib/lzo/lzo_compress.ko \
+       $(LINUX_DIR)/lib/lzo/lzo_decompress.ko
+  AUTOLOAD:=$(call AutoLoad,20, lzo_compress lzo_decompress,1)
+endef
+
+define KernelPackage/lib-lzo/description
+ Kernel module for LZO compression/decompression support
+endef
+
+$(eval $(call KernelPackage,lib-lzo))
+
+
 define KernelPackage/textsearch
 SUBMENU:=$(LIB_MENU)
   TITLE:=Textsearch support is selected if needed