ppp: rename 20-usb-modem to 20-atm-modem
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 2 May 2010 16:47:16 +0000 (16:47 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 2 May 2010 16:47:16 +0000 (16:47 +0000)
SVN-Revision: 21303

package/ppp/Makefile
package/ppp/files/etc/hotplug.d/atm/20-atm-modem [new file with mode: 0644]
package/ppp/files/etc/hotplug.d/atm/20-usb-modem [deleted file]

index 222c85deaef3aeaebe0f120b16bb117ed89050f3..66f72de21d86a671a5f35116bc07fc1b99aa3874 100644 (file)
@@ -150,7 +150,7 @@ define Package/ppp-mod-pppoa/install
        $(INSTALL_DIR) $(1)/lib/network
        $(INSTALL_BIN) ./files/pppoa.sh $(1)/lib/network/
        $(INSTALL_DIR) $(1)/etc/hotplug.d/atm
-       $(INSTALL_DATA) ./files/etc/hotplug.d/atm/20-usb-modem $(1)/etc/hotplug.d/atm/
+       $(INSTALL_DATA) ./files/etc/hotplug.d/atm/20-atm-modem $(1)/etc/hotplug.d/atm/
 endef
 
 define Package/ppp-mod-pppoe/install
diff --git a/package/ppp/files/etc/hotplug.d/atm/20-atm-modem b/package/ppp/files/etc/hotplug.d/atm/20-atm-modem
new file mode 100644 (file)
index 0000000..45ef542
--- /dev/null
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+if [ "$ACTION" = "add" ]; then
+       include /lib/network
+       scan_interfaces
+
+       local found=0
+       local ifc
+       for ifc in $interfaces; do
+               local up
+               config_get_bool up "$ifc" up 0
+
+               local proto
+               config_get proto "$ifc" proto
+
+               if [ "$proto" = "pppoa" ] && [ "$up" != 1 ]; then
+                       found=1
+                       ( sleep 1; ifup "$ifc" ) &
+               fi
+       done
+
+       if [ "$found" != 1 ]; then
+               logger "Found no matching interface for DSL device $DEVICENAME"
+       fi
+fi
diff --git a/package/ppp/files/etc/hotplug.d/atm/20-usb-modem b/package/ppp/files/etc/hotplug.d/atm/20-usb-modem
deleted file mode 100644 (file)
index 45ef542..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-
-if [ "$ACTION" = "add" ]; then
-       include /lib/network
-       scan_interfaces
-
-       local found=0
-       local ifc
-       for ifc in $interfaces; do
-               local up
-               config_get_bool up "$ifc" up 0
-
-               local proto
-               config_get proto "$ifc" proto
-
-               if [ "$proto" = "pppoa" ] && [ "$up" != 1 ]; then
-                       found=1
-                       ( sleep 1; ifup "$ifc" ) &
-               fi
-       done
-
-       if [ "$found" != 1 ]; then
-               logger "Found no matching interface for DSL device $DEVICENAME"
-       fi
-fi