kernel: add kmod-usb-net-ipheth (#10157)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 19:02:28 +0000 (19:02 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 19:02:28 +0000 (19:02 +0000)
SVN-Revision: 30981

package/kernel/modules/usb.mk

index e4f099510c94c0087ab0c37167e660bc7f49fcee..fedff208505e0d4eb4608c9862e9bb636c89f1cb 100644 (file)
@@ -913,6 +913,21 @@ endef
 $(eval $(call KernelPackage,usb-net-sierrawireless))
 
 
+define KernelPackage/usb-net-ipheth
+  TITLE:=Apple iPhone USB Ethernet driver
+  KCONFIG:=CONFIG_USB_IPHETH
+  FILES:=$(LINUX_DIR)/drivers/net/usb/ipheth.ko
+  AUTOLOAD:=$(call AutoLoad,64,ipheth)
+  $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-ipheth/description
+ Kernel support for Apple iPhone USB Ethernet driver
+endef
+
+$(eval $(call KernelPackage,usb-net-ipheth))
+
+
 define KernelPackage/usb-hid
   TITLE:=Support for USB Human Input Devices
   KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID CONFIG_USB_HIDDEV=y