kernel: add usb-dwc2 kmod
authorJohn Crispin <john@openwrt.org>
Mon, 15 Jul 2013 11:08:04 +0000 (11:08 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 15 Jul 2013 11:08:04 +0000 (11:08 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 37338

package/kernel/linux/modules/usb.mk

index 1cb8e2c1b257f235ae07fb448d2f357f38a9907b..0fa99ccb79bb89ae524a201d191e27ecd2758da0 100644 (file)
@@ -172,6 +172,29 @@ endef
 $(eval $(call KernelPackage,usb2-pci))
 
 
+define KernelPackage/usb-dwc2
+  TITLE:=DWC2 USB controller driver
+  DEPENDS:=@LINUX_3_10
+  KCONFIG:= \
+       CONFIG_USB_DWC2 \
+       CONFIG_USB_DWC2_DEBUG=n \
+       CONFIG_USB_DWC2_VERBOSE=n \
+       CONFIG_USB_DWC2_TRACK_MISSED_SOFS=n
+  FILES:= \
+       $(LINUX_DIR)/drivers/staging/dwc2/dwc2.ko \
+       $(LINUX_DIR)/drivers/staging/dwc2/dwc2_platform.ko
+  AUTOLOAD:=$(call AutoLoad,54,dwc2 dwc2_platform,1)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-dwc2/description
+  This driver provides USB Device Controller support for the
+  Synopsys DesignWare USB OTG Core.
+endef
+
+$(eval $(call KernelPackage,usb-dwc2))
+
+
 define KernelPackage/usb-acm
   TITLE:=Support for modems/isdn controllers
   KCONFIG:=CONFIG_USB_ACM