revert [8415], seems to be causing problems for the kernel build
authorFelix Fietkau <nbd@openwrt.org>
Thu, 16 Aug 2007 13:44:57 +0000 (13:44 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 16 Aug 2007 13:44:57 +0000 (13:44 +0000)
SVN-Revision: 8418

include/kernel.mk
package/kernel/Makefile

index 5b27d2f459c894033d548e062ee9b6ecb10e1ac0..df859a42b033ae5191870d7ecc527e90afeb2066 100644 (file)
@@ -51,9 +51,6 @@ endif
 GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
 GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
 
-ifeq ($(DUMP),)
-  -include $(LINUX_DIR)/.config
-endif
 
 define KernelPackage/Defaults
   FILES:=
index b805c6e19d73d8d9cbd9b09ed6f591a54ac1ed67..3ec07d43ac5deef00630a84d5354870bb15c3e56 100644 (file)
@@ -18,6 +18,7 @@ SCAN_DEPS=modules/*.mk
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
+  -include $(LINUX_DIR)/.config
   NF_KMOD:=1
   include $(INCLUDE_DIR)/netfilter.mk
 endif