brcm63xx: add DT support for USR9108
authorJonas Gorski <jogo@openwrt.org>
Mon, 8 Dec 2014 16:11:08 +0000 (16:11 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 8 Dec 2014 16:11:08 +0000 (16:11 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 43575

target/linux/brcm63xx/dts/usr9108.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
target/linux/brcm63xx/patches-3.18/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
target/linux/brcm63xx/profiles/usrobotics.mk [new file with mode: 0644]

diff --git a/target/linux/brcm63xx/dts/usr9108.dts b/target/linux/brcm63xx/dts/usr9108.dts
new file mode 100644 (file)
index 0000000..40d7e1c
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+       model = "USRobotics 9108";
+       compatible = "usr,9108", "brcm,bcm6348";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x3e0000>;
+       };
+
+       nvram@3f0000 {
+               label = "nvram";
+               reg = <0x3f0000 0x010000>;
+       };
+};
index 0e95a012b54a5cd3211cc6bcb29fee2192c448ad..ac15e003ddf0a63d3e0b6fe40278a1ddf5eb8468 100755 (executable)
@@ -200,9 +200,6 @@ define Image/Build
        # RTA1320_16M (numerous routers)
        $(call Image/Build/CFE,$(1),RTA1320_16M,6338,RTA1320_16M,,--layoutver 5)
 
-       # USR 9108
-       $(call Image/Build/CFE,$(1),96348GW-A,6348,USR9108)
-
        # Inventel Livebox
        $(call Image/Build/RedBoot,livebox)
 
@@ -333,6 +330,8 @@ $(eval $(call ImageDTB,CFEDTB,Neufbox4,nb4-ser-r0,96358VW,6358,NEUFBOX4-SER,--rs
 $(eval $(call ImageDTB,CFEDTB,Neufbox4,nb4-fxc-r1,96358VW,6358,NEUFBOX4-FXC,--rsa-signature "OpenWRT-$(REVISION)"))
 # SFR neufbox 6
 $(eval $(call ImageDTB,CFEDTB,Neufbox6,nb6-ser-r0,NB6-SER-r0,6362,NEUFBOX6,--rsa-signature "OpenWRT-$(REVISION)"))
+# USRobotics 9108
+$(eval $(call ImageDTB,CFEDTB,USR9108,usr9108,96348GW-A,6348,USR9108))
 # ZyXEL P870HW-51a v2
 $(eval $(call ImageDTB,ZYXCFEDTB,P870HW_51a_v2,p870hw-51a-v2,96368VVW,6368,P870HW-51a_v2,--rsa-signature "ZyXEL" --signature "ZyXEL_0001"))
 
index 63dc96919c8a34bb90f5be57c05afaa66f78a2e6..38ffe9b96f5cc6aa930bf2361eb993d30fd5db56 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -736,6 +736,48 @@ static const struct board_info __initcon
+@@ -736,6 +736,49 @@ static const struct board_info __initcon
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
@@ -43,6 +43,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 +      { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
 +      { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
 +      { .compatible = "tp-link,td-w8900gb", .data = &board_96348gw_11, },
++      { .compatible = "usr,9108", .data = &board_96348gw_a, },
 +#endif
 +#ifdef CONFIG_BCM63XX_CPU_6358
 +      { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
index 63dc96919c8a34bb90f5be57c05afaa66f78a2e6..38ffe9b96f5cc6aa930bf2361eb993d30fd5db56 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -736,6 +736,48 @@ static const struct board_info __initcon
+@@ -736,6 +736,49 @@ static const struct board_info __initcon
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
@@ -43,6 +43,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 +      { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
 +      { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
 +      { .compatible = "tp-link,td-w8900gb", .data = &board_96348gw_11, },
++      { .compatible = "usr,9108", .data = &board_96348gw_a, },
 +#endif
 +#ifdef CONFIG_BCM63XX_CPU_6358
 +      { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
diff --git a/target/linux/brcm63xx/profiles/usrobotics.mk b/target/linux/brcm63xx/profiles/usrobotics.mk
new file mode 100644 (file)
index 0000000..76b5e12
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/USR9108
+  NAME:=USRobotics 9108
+  PACKAGES:=kmod-b43 wpad-mini\
+       kmod-usb-ohci
+endef
+define Profile/USR9108/Description
+  Package set optimized for USR9108.
+endef
+$(eval $(call Profile,USR9108))