lantiq: add dsl-vr9-firmware-xdsl
authorJohn Crispin <john@openwrt.org>
Tue, 24 Nov 2015 20:40:11 +0000 (20:40 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 24 Nov 2015 20:40:11 +0000 (20:40 +0000)
This adds the DSL firmware for the VR9/XRX200 SoCs.

Signed-off-by: Hauke Mehrtens <hauke.mehrtens@lantiq.com>
SVN-Revision: 47631

package/firmware/lantiq/dsl-vr9-firmware-xdsl/Makefile [new file with mode: 0644]

diff --git a/package/firmware/lantiq/dsl-vr9-firmware-xdsl/Makefile b/package/firmware/lantiq/dsl-vr9-firmware-xdsl/Makefile
new file mode 100644 (file)
index 0000000..e03fc13
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2015 Lantiq Beteiligungs GmbH & Co KG.
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dsl_vr9_firmware_xdsl
+PKG_VERSION:=05.07.04.03.00.06_05.07.01.08.00.01_osc
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_MD5SUM:=4c8d9ca68dda88d3cfc0ca0fb946a63e
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/dsl-vr9-firmware-xdsl
+  SECTION:=firmware
+  CATEGORY:=Firmware
+  TITLE:=VR9 CPE xDSL firmware
+  URL:=http://www.lantiq.com/
+  DEPENDS:=@TARGET_lantiq_xrx200
+endef
+
+define Package/dsl-vr9-firmware-xdsl/description
+       VRX200 CPE xDSL firmware
+endef
+
+define Build/Prepare
+       rm -rf $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_BUILD_DIR)
+       $(TAR) -C $(PKG_BUILD_DIR) -xzf $(DL_DIR)/$(PKG_SOURCE)
+endef
+
+define Build/Compile
+endef
+
+define Package/dsl-vr9-firmware-xdsl/install
+       $(INSTALL_DIR) $(1)/lib/firmware/
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/LICENSE $(1)/lib/firmware/xcpe_574306_571801.LICENSE
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/xcpe_574306_571801.bin $(1)/lib/firmware/
+       ln -s xcpe_574306_571801.bin $(1)/lib/firmware/vdsl.bin
+endef
+
+$(eval $(call BuildPackage,dsl-vr9-firmware-xdsl))