ixp4xx: Split into two subtargets, one normal and one for boards which boot directly...
authorRod Whitby <rod@whitby.id.au>
Fri, 7 Dec 2007 22:29:44 +0000 (22:29 +0000)
committerRod Whitby <rod@whitby.id.au>
Fri, 7 Dec 2007 22:29:44 +0000 (22:29 +0000)
SVN-Revision: 9669

15 files changed:
target/linux/ixp4xx/Makefile
target/linux/ixp4xx/config/profile-FSG3 [deleted file]
target/linux/ixp4xx/fsg3/config-default [new file with mode: 0644]
target/linux/ixp4xx/fsg3/profiles/100-FSG3.mk [new file with mode: 0644]
target/linux/ixp4xx/fsg3/target.mk [new file with mode: 0644]
target/linux/ixp4xx/generic/profiles/100-Default.mk [new file with mode: 0644]
target/linux/ixp4xx/generic/profiles/200-NSLU2.mk [new file with mode: 0644]
target/linux/ixp4xx/generic/profiles/300-NAS100d.mk [new file with mode: 0644]
target/linux/ixp4xx/generic/profiles/400-DSMG600RevA.mk [new file with mode: 0644]
target/linux/ixp4xx/generic/target.mk [new file with mode: 0644]
target/linux/ixp4xx/profiles/100-Default.mk [deleted file]
target/linux/ixp4xx/profiles/200-NSLU2.mk [deleted file]
target/linux/ixp4xx/profiles/300-NAS100d.mk [deleted file]
target/linux/ixp4xx/profiles/400-DSMG600RevA.mk [deleted file]
target/linux/ixp4xx/profiles/500-FSG3.mk [deleted file]

index 6e945aba2c5c59122b326cf2cd9a05e4dc428b7d..5b9d3fb551413af6ad88ddb989d9edeaad52a640 100644 (file)
@@ -10,6 +10,7 @@ ARCH:=armeb
 BOARD:=ixp4xx
 BOARDNAME:=Intel XScale IXP4xx
 FEATURES:=squashfs
+SUBTARGETS=generic fsg3
 
 LINUX_VERSION:=2.6.21.6
 
diff --git a/target/linux/ixp4xx/config/profile-FSG3 b/target/linux/ixp4xx/config/profile-FSG3
deleted file mode 100644 (file)
index 6dfaae0..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-CONFIG_CMDLINE="root=/dev/sda1 noinitrd console=ttyS0,115200"
-CONFIG_ATA=y
-CONFIG_SATA_VIA=y
-CONFIG_USB_ARCH_HAS_HCD=y
-CONFIG_USB_ARCH_HAS_OHCI=y
-CONFIG_USB_ARCH_HAS_EHCI=y
-CONFIG_USB=y
-CONFIG_USB_EHCI_HCD=y
-CONFIG_USB_EHCI_SPLIT_ISO=y
-CONFIG_USB_EHCI_ROOT_HUB_TT=y
-CONFIG_USB_EHCI_TT_NEWSCHED=y
-CONFIG_USB_OHCI_HCD=y
-CONFIG_USB_OHCI_LITTLE_ENDIAN=y
-CONFIG_USB_STORAGE=y
-CONFIG_EXT3_FS=y
-CONFIG_EXT3_FS_XATTR=y
-CONFIG_EXT3_FS_POSIX_ACL=y
-CONFIG_EXT3_FS_SECURITY=y
-CONFIG_JBD=y
-CONFIG_FS_MBCACHE=y
-CONFIG_BLK_DEV_SD=y
-CONFIG_REISERFS_FS=y
diff --git a/target/linux/ixp4xx/fsg3/config-default b/target/linux/ixp4xx/fsg3/config-default
new file mode 100644 (file)
index 0000000..6dfaae0
--- /dev/null
@@ -0,0 +1,22 @@
+CONFIG_CMDLINE="root=/dev/sda1 noinitrd console=ttyS0,115200"
+CONFIG_ATA=y
+CONFIG_SATA_VIA=y
+CONFIG_USB_ARCH_HAS_HCD=y
+CONFIG_USB_ARCH_HAS_OHCI=y
+CONFIG_USB_ARCH_HAS_EHCI=y
+CONFIG_USB=y
+CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_EHCI_SPLIT_ISO=y
+CONFIG_USB_EHCI_ROOT_HUB_TT=y
+CONFIG_USB_EHCI_TT_NEWSCHED=y
+CONFIG_USB_OHCI_HCD=y
+CONFIG_USB_OHCI_LITTLE_ENDIAN=y
+CONFIG_USB_STORAGE=y
+CONFIG_EXT3_FS=y
+CONFIG_EXT3_FS_XATTR=y
+CONFIG_EXT3_FS_POSIX_ACL=y
+CONFIG_EXT3_FS_SECURITY=y
+CONFIG_JBD=y
+CONFIG_FS_MBCACHE=y
+CONFIG_BLK_DEV_SD=y
+CONFIG_REISERFS_FS=y
diff --git a/target/linux/ixp4xx/fsg3/profiles/100-FSG3.mk b/target/linux/ixp4xx/fsg3/profiles/100-FSG3.mk
new file mode 100644 (file)
index 0000000..f06fa8c
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FSG3
+  NAME:=Freecom FSG-3
+  PACKAGES:= \
+       kmod-madwifi wireless-tools \
+       kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
+       kmod-fs-ext2 kmod-fs-reiserfs
+endef
+
+define Profile/FSG3/Description
+       Package set optimized for the Freecom FSG-3
+endef
+$(eval $(call Profile,FSG3))
+
diff --git a/target/linux/ixp4xx/fsg3/target.mk b/target/linux/ixp4xx/fsg3/target.mk
new file mode 100644 (file)
index 0000000..c71065e
--- /dev/null
@@ -0,0 +1,6 @@
+BOARDNAME:=Internal Hard-Disk
+
+define Target/Description
+       Build firmware images for ixp4xx based boards that boot directly from internal disk storage
+       (e.g : Freecom FSG-3, ...)
+endef
diff --git a/target/linux/ixp4xx/generic/profiles/100-Default.mk b/target/linux/ixp4xx/generic/profiles/100-Default.mk
new file mode 100644 (file)
index 0000000..104268b
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+  NAME:=Default Profile
+  PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Default/Description
+       Default IXP4xx Profile
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk b/target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
new file mode 100644 (file)
index 0000000..a4e1a30
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NSLU2
+  NAME:=Linksys NSLU2
+  PACKAGES:=kmod-ixp4xx-npe \
+       kmod-scsi-core \
+       kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
+       kmod-fs-ext2 kmod-fs-ext3
+endef
+
+define Profile/NSLU2/Description
+       Package set optimized for the Linksys NSLU2
+endef
+$(eval $(call Profile,NSLU2))
+
diff --git a/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk b/target/linux/ixp4xx/generic/profiles/300-NAS100d.mk
new file mode 100644 (file)
index 0000000..2a43ac6
--- /dev/null
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NAS100d
+  NAME:=Iomega NAS 100d
+  PACKAGES:=kmod-ixp4xx-npe \
+       kmod-madwifi wireless-tools \
+       kmod-scsi-core \
+       kmod-ata-core kmod-ata-artop \
+       kmod-usb-core kmod-usb2 kmod-usb-storage \
+       kmod-fs-ext2 kmod-fs-ext3
+endef
+
+define Profile/NAS100d/Description
+       Package set optimized for the Iomega NAS 100d
+endef
+$(eval $(call Profile,NAS100d))
+
diff --git a/target/linux/ixp4xx/generic/profiles/400-DSMG600RevA.mk b/target/linux/ixp4xx/generic/profiles/400-DSMG600RevA.mk
new file mode 100644 (file)
index 0000000..aa2c642
--- /dev/null
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DSMG600RevA
+  NAME:=DSM-G600 Rev A
+  PACKAGES:=kmod-via-velocity \
+       kmod-madwifi wireless-tools \
+       kmod-scsi-core \
+       kmod-ata-core kmod-ata-artop \
+       kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
+       kmod-fs-ext2 kmod-fs-ext3
+endef
+
+define Profile/DSMG600RevA/Description
+       Package set optimized for the DSM-G600 Rev A
+endef
+$(eval $(call Profile,DSMG600RevA))
+
diff --git a/target/linux/ixp4xx/generic/target.mk b/target/linux/ixp4xx/generic/target.mk
new file mode 100644 (file)
index 0000000..21fd5d4
--- /dev/null
@@ -0,0 +1,7 @@
+BOARDNAME:=Generic
+
+define Target/Description
+       Build firmware images for ixp4xx based boards that boot from internal flash
+       (e.g : Linksys NSLU2, ...)
+endef
+
diff --git a/target/linux/ixp4xx/profiles/100-Default.mk b/target/linux/ixp4xx/profiles/100-Default.mk
deleted file mode 100644 (file)
index 104268b..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-  NAME:=Default Profile
-  PACKAGES:=kmod-madwifi
-endef
-
-define Profile/Default/Description
-       Default IXP4xx Profile
-endef
-$(eval $(call Profile,Default))
-
diff --git a/target/linux/ixp4xx/profiles/200-NSLU2.mk b/target/linux/ixp4xx/profiles/200-NSLU2.mk
deleted file mode 100644 (file)
index a4e1a30..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/NSLU2
-  NAME:=Linksys NSLU2
-  PACKAGES:=kmod-ixp4xx-npe \
-       kmod-scsi-core \
-       kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
-       kmod-fs-ext2 kmod-fs-ext3
-endef
-
-define Profile/NSLU2/Description
-       Package set optimized for the Linksys NSLU2
-endef
-$(eval $(call Profile,NSLU2))
-
diff --git a/target/linux/ixp4xx/profiles/300-NAS100d.mk b/target/linux/ixp4xx/profiles/300-NAS100d.mk
deleted file mode 100644 (file)
index 2a43ac6..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/NAS100d
-  NAME:=Iomega NAS 100d
-  PACKAGES:=kmod-ixp4xx-npe \
-       kmod-madwifi wireless-tools \
-       kmod-scsi-core \
-       kmod-ata-core kmod-ata-artop \
-       kmod-usb-core kmod-usb2 kmod-usb-storage \
-       kmod-fs-ext2 kmod-fs-ext3
-endef
-
-define Profile/NAS100d/Description
-       Package set optimized for the Iomega NAS 100d
-endef
-$(eval $(call Profile,NAS100d))
-
diff --git a/target/linux/ixp4xx/profiles/400-DSMG600RevA.mk b/target/linux/ixp4xx/profiles/400-DSMG600RevA.mk
deleted file mode 100644 (file)
index aa2c642..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DSMG600RevA
-  NAME:=DSM-G600 Rev A
-  PACKAGES:=kmod-via-velocity \
-       kmod-madwifi wireless-tools \
-       kmod-scsi-core \
-       kmod-ata-core kmod-ata-artop \
-       kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
-       kmod-fs-ext2 kmod-fs-ext3
-endef
-
-define Profile/DSMG600RevA/Description
-       Package set optimized for the DSM-G600 Rev A
-endef
-$(eval $(call Profile,DSMG600RevA))
-
diff --git a/target/linux/ixp4xx/profiles/500-FSG3.mk b/target/linux/ixp4xx/profiles/500-FSG3.mk
deleted file mode 100644 (file)
index f06fa8c..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/FSG3
-  NAME:=Freecom FSG-3
-  PACKAGES:= \
-       kmod-madwifi wireless-tools \
-       kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
-       kmod-fs-ext2 kmod-fs-reiserfs
-endef
-
-define Profile/FSG3/Description
-       Package set optimized for the Freecom FSG-3
-endef
-$(eval $(call Profile,FSG3))
-