brcm2708: fix image generation with imagebuilder
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Thu, 13 Oct 2016 17:01:41 +0000 (19:01 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Thu, 13 Oct 2016 17:01:41 +0000 (19:01 +0200)
COPYING is not present in $(LINUX_DIR) on imagebuilder and prevents a
successful image creation.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/brcm2708/image/Makefile

index f19f57cb2ce1add051f6595b4f20c23256e3231a..d0222df0652b7d155a5de5ccc095eaeec5691a09 100644 (file)
@@ -12,6 +12,10 @@ include $(INCLUDE_DIR)/host.mk
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
+define Build/Compile
+       $(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
+endef
+
 ### Image scripts ###
 define Build/kernel-img
        perl $(LINUX_DIR)/scripts/mkknlimg $@ $@.tmp
@@ -21,7 +25,7 @@ endef
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot $(FAT32_BLOCKS)
-       mcopy -i $@.boot $(LINUX_DIR)/COPYING ::COPYING.linux
+       mcopy -i $@.boot $(KDIR)/COPYING.linux ::
        mcopy -i $@.boot $(KDIR)/bootcode.bin ::
        mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
        mcopy -i $@.boot $(KDIR)/start.elf ::