add initial support for the WZR-AGL300NH - patch by Joonas Lahtinen <joonas.lahtinen...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 24 Jan 2010 23:31:49 +0000 (23:31 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 24 Jan 2010 23:31:49 +0000 (23:31 +0000)
SVN-Revision: 19321

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/common/prom.c
target/linux/ramips/files/arch/mips/ralink/rt288x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt288x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt288x/mach-wzr-agl300nh.c [new file with mode: 0644]
target/linux/ramips/rt288x/config-2.6.30

index 100ccfd71fcd5e1cdbeee8819dad43655852a24f..08e939d5d90dd494e7334b4e959bd5de59d49ad8 100644 (file)
@@ -1,6 +1,7 @@
 /*
  * Ralink machine types
  *
+ * Copyright (C) 2010 Joonas Lahtinen <joonas.lahtinen@gmail.com>
  * Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
  *
  * This program is free software; you can redistribute it and/or modify it
@@ -12,6 +13,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_GENERIC,
        /* RT2880 based machines */
        RAMIPS_MACH_RT_N15,             /* Asus RT-N15 */
+       RAMIPS_MACH_WZR_AGL300NH,       /* Buffalo WZR-AGL300NH */
 
        /* RT3050 based machines */
        RAMIPS_MACH_DIR_300_REVB,       /* D-Link DIR-300 rev B */
index 5dad9c28fbbde52a4165c25d4b0ed2788448f21b..154d5f9f2600e155aed9d157e5365339908e1dcd 100644 (file)
@@ -1,6 +1,7 @@
 /*
  *  Ralink SoC specific prom routines
  *
+ *  Copyright (C) 2010 Joonas Lahtinen <joonas.lahtinen@gmail.com>
  *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
  *
  *  This program is free software; you can redistribute it and/or modify it
@@ -28,6 +29,9 @@ static struct board_rec boards[] __initdata = {
        {
                .name           = "RT-N15",
                .mach_type      = RAMIPS_MACH_RT_N15,
+       }, {
+               .name           = "WZR-AGL300NH",
+               .mach_type      = RAMIPS_MACH_WZR_AGL300NH,
        }, {
                .name           = "DIR-300-revB",
                .mach_type      = RAMIPS_MACH_DIR_300_REVB,
index 3c7df5fcf739fbb4a5aeecb0ea932b6701249822..1b0b85468b7c871167cf5a4225414b89853c5895 100644 (file)
@@ -7,6 +7,11 @@ config RT288X_MACH_RT_N15
        default y
        select RALINK_DEV_GPIO_LEDS
 
+config RT288X_MACH_WZR_AGL300NH
+       bool "Buffalo WZR-AGL300NH board support"
+       default y
+       select RALINK_DEV_GPIO_LEDS
+
 endmenu
 
 endif
index ab98fac7e5da62b37e5fcccb53c78f344ba09361..dda3e063fa82d09a90363d10ed0316e186ef0a34 100644 (file)
@@ -1,6 +1,7 @@
 #
 # Makefile for the Ralink RT288x SoC specific parts of the kernel
 #
+# Copyright (C) 2010 Joonas Lahtinen <joonas.lahtinen@gmail.com>
 # Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
 # Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
 #
@@ -13,3 +14,5 @@ obj-y := irq.o setup.o rt288x.o devices.o
 obj-$(CONFIG_EARLY_PRINTK)             += early_printk.o
 
 obj-$(CONFIG_RT288X_MACH_RT_N15)       += mach-rt-n15.o
+
+obj-$(CONFIG_RT288X_MACH_WZR_AGL300NH) += mach-wzr-agl300nh.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-wzr-agl300nh.c b/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-wzr-agl300nh.c
new file mode 100644 (file)
index 0000000..c0a09cf
--- /dev/null
@@ -0,0 +1,105 @@
+/*
+ *  Buffalo WZR-AGL300NH board support
+ *
+ *  Copyright (C) 2010 Joonas Lahtinen <joonas.lahtinen@gmail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+#include <linux/leds.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev_gpio_leds.h>
+#include <asm/mach-ralink/rt288x.h>
+#include <asm/mach-ralink/rt288x_regs.h>
+
+#include "devices.h"
+
+#if 0
+#define WZR_AGL300NH_GPIO_LED_POWER    XX
+#define WZR_AGL300NH_GPIO_BUTTON_AOSS  XX
+#define WZR_AGL300NH_GPIO_BUTTON_RESET XX
+#endif // 0
+
+#ifdef CONFIG_MTD_PARTITIONS
+
+/*
+From stock firmware:
+mtd0: 00030000 00010000 "uboot"
+mtd1: 00010000 00010000 "uboot_environ"
+mtd2: 00010000 00010000 "factory_default"
+mtd3: 000b0000 00010000 "linux"
+mtd4: 002f0000 00010000 "rootfs"
+mtd5: 00010000 00010000 "user_property"
+*/
+
+static struct mtd_partition wzr_agl300nh_partitions[] = {
+       {
+               .name   = "uboot",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "uboot_environ",
+               .offset = 0x030000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "factory_default",
+               .offset = 0x040000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "linux",
+               .offset = 0x050000,
+               .size   = 0x0b0000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x100000,
+               .size   = 0x2f0000,
+       }, {
+               .name   = "user_property",
+               .offset = 0x3f0000,
+               .size   = 0x010000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data wzr_agl300nh_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(wzr_agl300nh_partitions),
+       .parts          = wzr_agl300nh_partitions,
+#endif
+};
+
+#if 0
+static struct gpio_led wzr_agl300nh_leds_gpio[] __initdata = {
+       {
+               .name           = "wzr-agl300nh:green:power",
+               .gpio           = WZR_AGL300NH_GPIO_LED_POWER,
+               .active_low     = ??,
+       }
+};
+#endif
+
+static void __init wzr_agl300nh_init(void)
+{
+       rt288x_gpio_init(RT2880_GPIO_MODE_UART0);
+
+       rt288x_register_flash(0, &wzr_agl300nh_flash_data);
+
+/*
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(wzr_agl300nh_leds_gpio),
+                                 wzr_agl300nh_leds_gpio);
+*/
+}
+
+MIPS_MACHINE(RAMIPS_MACH_WZR_AGL300NH, "Buffalo WZR-AGL300NH", wzr_agl300nh_init);
index 03a6797206ce290ac9182e823be672ba8fb2f83f..0167eb5aa9e6eee53b4fb3c607d7678c74a2a068 100644 (file)
@@ -13,8 +13,8 @@ CONFIG_BITREVERSE=y
 # CONFIG_CAVIUM_OCTEON_REFERENCE_BOARD is not set
 # CONFIG_CAVIUM_OCTEON_SIMULATOR is not set
 CONFIG_CC_OPTIMIZE_FOR_SIZE=y
-CONFIG_CEVT_R4K_LIB=y
 CONFIG_CEVT_R4K=y
+CONFIG_CEVT_R4K_LIB=y
 CONFIG_CMDLINE="console=ttyS1,57600 rootfstype=squashfs,jffs2"
 # CONFIG_CPU_BIG_ENDIAN is not set
 # CONFIG_CPU_CAVIUM_OCTEON is not set
@@ -23,9 +23,9 @@ CONFIG_CPU_HAS_PREFETCH=y
 CONFIG_CPU_HAS_SYNC=y
 CONFIG_CPU_LITTLE_ENDIAN=y
 # CONFIG_CPU_LOONGSON2 is not set
+CONFIG_CPU_MIPS32=y
 # CONFIG_CPU_MIPS32_R1 is not set
 CONFIG_CPU_MIPS32_R2=y
-CONFIG_CPU_MIPS32=y
 # CONFIG_CPU_MIPS64_R1 is not set
 # CONFIG_CPU_MIPS64_R2 is not set
 CONFIG_CPU_MIPSR2=y
@@ -47,16 +47,16 @@ CONFIG_CPU_SUPPORTS_HIGHMEM=y
 # CONFIG_CPU_TX39XX is not set
 # CONFIG_CPU_TX49XX is not set
 # CONFIG_CPU_VR41XX is not set
-CONFIG_CSRC_R4K_LIB=y
 CONFIG_CSRC_R4K=y
+CONFIG_CSRC_R4K_LIB=y
 CONFIG_DECOMPRESS_LZMA=y
 CONFIG_DEVPORT=y
 # CONFIG_DM9000 is not set
 CONFIG_DMA_NEED_PCI_MAP_STATE=y
 CONFIG_DMA_NONCOHERENT=y
 CONFIG_EARLY_PRINTK=y
-CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
 CONFIG_GENERIC_CLOCKEVENTS=y
+CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
 CONFIG_GENERIC_CMOS_UPDATE=y
 CONFIG_GENERIC_FIND_LAST_BIT=y
 CONFIG_GENERIC_FIND_NEXT_BIT=y
@@ -88,8 +88,8 @@ CONFIG_IRQ_CPU=y
 # CONFIG_MACH_VR41XX is not set
 # CONFIG_MII is not set
 # CONFIG_MIKROTIK_RB532 is not set
+CONFIG_MIPS=y
 # CONFIG_MIPS_COBALT is not set
-# CONFIG_MIPS_FPU_EMU is not set
 CONFIG_MIPS_L1_CACHE_SHIFT=4
 CONFIG_MIPS_MACHINE=y
 # CONFIG_MIPS_MALTA is not set
@@ -97,8 +97,8 @@ CONFIG_MIPS_MT_DISABLED=y
 # CONFIG_MIPS_MT_SMP is not set
 # CONFIG_MIPS_MT_SMTC is not set
 CONFIG_MIPS_RALINK=y
+# CONFIG_MIPS_RAMIPS_NET is not set
 # CONFIG_MIPS_SIM is not set
-CONFIG_MIPS=y
 # CONFIG_MTD_CFI_INTELEXT is not set
 # CONFIG_MTD_COMPLEX_MAPPINGS is not set
 CONFIG_MTD_PHYSMAP=y
@@ -117,6 +117,7 @@ CONFIG_RALINK_DEV_GPIO_LEDS=y
 CONFIG_RALINK_RT288X=y
 # CONFIG_RALINK_RT305X is not set
 CONFIG_RT288X_MACH_RT_N15=y
+CONFIG_RT288X_MACH_WZR_AGL300NH=y
 CONFIG_SCHED_OMIT_FRAME_POINTER=y
 # CONFIG_SCSI_DMA is not set
 # CONFIG_SERIAL_8250_EXTENDED is not set