ath79: update WA/XC devices UBNT_VERSION to 8.5.3
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>
Thu, 28 May 2020 09:44:54 +0000 (11:44 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 3 Jun 2020 13:29:20 +0000 (15:29 +0200)
Ubiquiti WA devices with newer hw version 2011K require UBNT_VERSION
to be at least 8.5.3, otherwise the image is rejected:

   New ver: WA.ar934x.v8.5.0-42.OpenWrt-r10947-65030d81f3
   Versions: New(525568) 8.5.0, Required(525571) 8.5.3
   Invalid version 'WA.ar934x.v8.5.0-42.OpenWrt-r10947-65030d81f3'

For consistency, also increase version number for XC devices.

Tested-by: Pedro <pedrowrt@cas.cat>
Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
(cherry picked from commit 95caa3436d98dac3709e550765f3f86d11a99782)

target/linux/ath79/image/generic-ubnt.mk

index f34ffa1612ec3e97bf239fa07ae40c669e6dc6d9..d16d820fbc7e865ad1cd30dfca14bb76940e7695 100644 (file)
@@ -32,7 +32,7 @@ endef
 # UBNT_BOARD e.g. one of (XS2, XS5, RS, XM)
 # UBNT_TYPE e.g. one of (BZ, XM, XW)
 # UBNT_CHIP e.g. one of (ar7240, ar933x, ar934x)
-# UBNT_VERSION e.g. one of (6.0.0, 8.5.0)
+# UBNT_VERSION e.g. one of (6.0.0, 8.5.3)
 define Device/ubnt
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2
   IMAGE_SIZE := 7552k
@@ -64,7 +64,7 @@ define Device/ubnt-wa
   UBNT_TYPE := WA
   UBNT_CHIP := ar934x
   UBNT_BOARD := WA
-  UBNT_VERSION := 8.5.0
+  UBNT_VERSION := 8.5.3
   ATH_SOC := ar9342
 endef