upgrade to 2.6.24.5
authorImre Kaloz <kaloz@openwrt.org>
Mon, 28 Apr 2008 10:23:36 +0000 (10:23 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 28 Apr 2008 10:23:36 +0000 (10:23 +0000)
SVN-Revision: 10959

16 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar7/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm63xx/Makefile
target/linux/generic-2.6/patches-2.6.24/700-powerpc_git.patch
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/magicbox/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/rdc/Makefile
target/linux/sibyte/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile

index 71e4f12837dc5193f0eb9620af27242e7145882a..de07e90cedbbb716ddec87ba1ddd94c8c40bcbea 100644 (file)
@@ -22,8 +22,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.23.16)
   LINUX_KERNEL_MD5SUM:=2637a7f1d4450bc5e27422f307fc6529
 endif
-ifeq ($(LINUX_VERSION),2.6.24.2)
-  LINUX_KERNEL_MD5SUM:=dd573a2fae55624ed92fa49c17583964
+ifeq ($(LINUX_VERSION),2.6.24.5)
+  LINUX_KERNEL_MD5SUM:=26500f8f92895bd33e391088b5edd4ad
 endif
 ifeq ($(LINUX_VERSION),2.6.25)
   LINUX_KERNEL_MD5SUM:=db95a49a656a3247d4995a797d333153
index a397f2a26f7ddec260b0a690cd4f3e794cfdcfd0..4cc10ef6202739eff1f066ccbed88b85c94f4158 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon ADM5120
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index fc83f9a0501086ae955b488c021fed07d8b5361d..5ce6e630ef5cdcad2233629779540d75ca88115b 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 4566d6c4cb871d776da730d9688f181746ebc437..3b16c4259eee48775ff36b085ecdba97157975ba 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=au1000
 BOARDNAME:=AMD Alchemy AU1x00
 FEATURES:=jffs2 usb pci
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += yamonenv
index 4b492845bc9869df9b1883d812401229204cfa3b..ec1a959ed2955c58f028f1e6e84a4b244e265784 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 4e56dd72f233b99049631fc5d91ee1253669d5bd..457a67e6f346277fb821b495537b74b701c96673 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
 FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 2aff3a7aeb81041b241161b700bdfa1ababa20ad..d31c2bb8037c1afe45390e1e5a3aec3c2adb8aca 100644 (file)
@@ -49955,21 +49955,6 @@ diff -x .git -x .gitignore -Nur linux-2.6.24/arch/powerpc/platforms/chrp/pci.c p
        /* keep the reference to the root node */
  }
  
-@@ -354,7 +354,7 @@
-  * mode as well. The same fixup must be done to the class-code property in
-  * the IDE node /pci@80000000/ide@C,1
-  */
--static void __devinit chrp_pci_fixup_vt8231_ata(struct pci_dev *viaide)
-+static void chrp_pci_fixup_vt8231_ata(struct pci_dev *viaide)
- {
-       u8 progif;
-       struct pci_dev *viaisa;
-@@ -375,4 +375,4 @@
-       pci_dev_put(viaisa);
- }
--DECLARE_PCI_FIXUP_EARLY(PCI_VENDOR_ID_VIA, PCI_DEVICE_ID_VIA_82C586_1, chrp_pci_fixup_vt8231_ata);
-+DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_VIA, PCI_DEVICE_ID_VIA_82C586_1, chrp_pci_fixup_vt8231_ata);
 diff -x .git -x .gitignore -Nur linux-2.6.24/arch/powerpc/platforms/chrp/setup.c powerpc.git/arch/powerpc/platforms/chrp/setup.c
 --- linux-2.6.24/arch/powerpc/platforms/chrp/setup.c   2008-01-24 23:58:37.000000000 +0100
 +++ powerpc.git/arch/powerpc/platforms/chrp/setup.c    2008-01-28 20:25:49.000000000 +0100
@@ -64602,7 +64587,7 @@ diff -x .git -x .gitignore -Nur linux-2.6.24/drivers/macintosh/via-pmu.c powerpc
  EXPORT_SYMBOL(pmu_suspend);
  EXPORT_SYMBOL(pmu_resume);
  EXPORT_SYMBOL(pmu_unlock);
--#if defined(CONFIG_PM_SLEEP) && defined(CONFIG_PPC32)
+-#if defined(CONFIG_PPC32)
 +#if defined(CONFIG_SUSPEND) && defined(CONFIG_PPC32)
  EXPORT_SYMBOL(pmu_enable_irled);
  EXPORT_SYMBOL(pmu_battery_count);
index 82a3367a6a515411dffe26c33c490c261fcaf946..41265ef9ff018375a9c20f6a736f89dc225052a1 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=iop32x
 BOARDNAME:=Intel XScale IOP32x
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 
 include $(INCLUDE_DIR)/target.mk
 
index f6e9d47eee48bd93aad20d39fa70d3c76a19c575..83dc1ddec32032fc9c129bf2cfdda33464976061 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel XScale IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 
 include $(INCLUDE_DIR)/target.mk
 
index c03093e00e316608de789600d5a5744c557fef67..548b960c1bff2b257998e0194af0a24ae4b44184 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=squashfs pci
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk
index b081849db803dc646fa6b425f6e6518e4ec6dd4e..2fdc1b0db9e624d926dfd4a7fdffca0cc2269548 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc40x
 BOARDNAME:=AMCC Kilauea
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 7e7061265b0a90741cff8613e00a5436eb90f12e..0a5fd353120f97f3e1d79b531ba7fde3f4dd6aed 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc44x
 BOARDNAME:=AMCC Taishan
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 4e83e163d74acd4eb50589b9ceef7abfb331808b..d840a4285051d1094de867d07fc6b8b49e8f9602 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rdc
 BOARDNAME:=RDC321x x86
 FEATURES:=squashfs jffs2 pci
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 
 include $(INCLUDE_DIR)/target.mk
 
index dfc863222d1ba7edd6545665216111186898b160..df4539ca935102036d79f656eb216cfca44308b1 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=sibyte
 BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=broken
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 
 include $(INCLUDE_DIR)/target.mk
 
index ebcfbbc99a64e539144439980b76913de23533a1..543f7036e2e5a5e9b0e92c8d7cae83919140717b 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=broken ext2
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 
 include $(INCLUDE_DIR)/target.mk
 
index 4a7cdd615f94c32d58ce6554d19fda023576b8b7..4663c3d5aa385188c83afc71e889ce10d3b3f277 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2
 SUBTARGETS=generic mediacenter
 
-LINUX_VERSION:=2.6.24.2
+LINUX_VERSION:=2.6.24.5
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci