kernel: add kmod-usb-serial-qualcomm (#8283)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 18:49:38 +0000 (18:49 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 18:49:38 +0000 (18:49 +0000)
SVN-Revision: 30979

package/kernel/modules/usb.mk

index d454947d9399227c1b91176c130214ece1f79ec8..e4f099510c94c0087ab0c37167e660bc7f49fcee 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -606,6 +606,20 @@ endef
 $(eval $(call KernelPackage,usb-serial-option))
 
 
+define KernelPackage/usb-serial-qualcomm
+  TITLE:=Support for Qualcomm USB serial
+  KCONFIG:=CONFIG_USB_SERIAL_QUALCOMM
+  FILES:=$(LINUX_DIR)/drivers/usb/serial/qcserial.ko
+  AUTOLOAD:=$(call AutoLoad,65,qcserial)
+endef
+
+define KernelPackage/usb-serial-qualcomm/description
+ Kernel support for Qualcomm USB Serial devices (Gobi)
+endef
+
+$(eval $(call KernelPackage,usb-serial-qualcomm))
+
+
 define KernelPackage/usb-storage
   TITLE:=USB Storage support
   DEPENDS:= +kmod-scsi-core