omap: add profile for BeagleBoard
authorJohn Crispin <john@openwrt.org>
Thu, 2 Apr 2015 14:31:51 +0000 (14:31 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 2 Apr 2015 14:31:51 +0000 (14:31 +0000)
original BeagleBoard has no Ethernet
provide a profile with all available USB Ethernet adapters
EBVBeagle comes with a kmod-usb-net-mcs7830 compatible device

tested with BeagleBoard C4

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
SVN-Revision: 45237

target/linux/omap/profiles/beagleboard.mk [new file with mode: 0644]

diff --git a/target/linux/omap/profiles/beagleboard.mk b/target/linux/omap/profiles/beagleboard.mk
new file mode 100644 (file)
index 0000000..4658287
--- /dev/null
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BEAGLEBOARD
+       NAME:=EBV BeagleBoard
+       FEATURES:= usb ext4 targz
+       DEFAULT_PACKAGES += kmod-usb2 kmod-usb2-omap \
+                       kmod-usb-net kmod-usb-net-asix \
+                       kmod-usb-net-asix-ax88179 kmod-usb-net-hso \
+                       kmod-usb-net-kaweth kmod-usb-net-pegasus \
+                       kmod-usb-net-mcs7830 kmod-usb-net-smsc95xx \
+                       kmod-usb-net-dm9601-ether
+endef
+
+define Profile/BEAGLEBOARD/Description
+       Package set for the BEAGLEBOARD and similar devices.
+       Contains various USB-NET drivers for boards without Ethernet.
+endef
+
+$(eval $(call Profile,BEAGLEBOARD))