openssl: Support multi-threaded applications
authorFelix Fietkau <nbd@openwrt.org>
Sat, 14 Dec 2013 10:19:48 +0000 (10:19 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 14 Dec 2013 10:19:48 +0000 (10:19 +0000)
Allow multi-threaded applications to work properly by
removing the "no-threads" flag that is enabled by default.

Signed-off-by: Sujith Manoharan <c_manoha@qca.qualcomm.com>
SVN-Revision: 39048

package/libs/openssl/Makefile

index 27b6e99e3bfcccc52b037455019c4490717e3347..f2898371c892dbfb5963dbf764db49e77cfffc13 100644 (file)
@@ -79,7 +79,7 @@ endef
 
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
        no-aes192 no-camellia no-ans1 no-krb5
-OPENSSL_OPTIONS:= shared no-err no-hw no-threads zlib-dynamic no-sse2
+OPENSSL_OPTIONS:= shared no-err no-hw zlib-dynamic no-sse2
 
 ifdef CONFIG_OPENSSL_ENGINE_CRYPTO
   OPENSSL_OPTIONS += -DHAVE_CRYPTODEV