ar71xx: add support for tp-link wr740n v5.0 (EU)
authorLuka Perkov <luka@openwrt.org>
Tue, 23 Jun 2015 05:21:50 +0000 (05:21 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 23 Jun 2015 05:21:50 +0000 (05:21 +0000)
TP-Link ships wr740n v5.0 to Romania (so probably everywhere except
China) with 4 MB flash and 32 MB memory (confirmed by their local
support). This patch adds support for the v5.0 clone of v4, i just
tested it on my own v5.0 router and it works.

Signed-off-by: Daniel Petre <daniel.petre@posteo.net>
SVN-Revision: 46115

target/linux/ar71xx/image/Makefile

index 1d860f91f8e24979dd95cd080c6de7c1d6ab2914..3956927ce4002874f11b1e8803fc5a3725d68442 100644 (file)
@@ -510,6 +510,14 @@ define Device/tl-wr740n-v4
     CONSOLE := ttyATH0,115200
 endef
 
+define Device/tl-wr740n-v5
+    $(Device/tplink-4mlzma)
+    BOARDNAME := TL-WR741ND-v4
+    DEVICE_PROFILE := TLWR740
+    TPLINK_HWID := 0x07400005
+    CONSOLE := ttyATH0,115200
+endef
+
 define Device/tl-wr741nd-v1
     $(Device/tplink-4m)
     BOARDNAME := TL-WR741ND
@@ -539,7 +547,7 @@ define Device/tl-wr743nd-v2
     TPLINK_HWID := 0x07430002
     CONSOLE := ttyATH0,115200
 endef
-TARGET_DEVICES += tl-wr740n-v4 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr743nd-v2
+TARGET_DEVICES += tl-wr740n-v4 tl-wr740n-v5 tl-wr741nd-v1 tl-wr741nd-v2 tl-wr741nd-v4 tl-wr743nd-v2
 
 define Device/tl-wr841n-v8
     $(Device/tplink-4mlzma)