build: unify target independent optimization options
authorFelix Fietkau <nbd@openwrt.org>
Mon, 29 Jul 2013 09:38:29 +0000 (09:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 29 Jul 2013 09:38:29 +0000 (09:38 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37600

33 files changed:
Config.in
include/target.mk
rules.mk
target/linux/ar71xx/Makefile
target/linux/at91/Makefile
target/linux/cns21xx/Makefile
target/linux/cns3xxx/Makefile
target/linux/cobalt/Makefile
target/linux/ep93xx/Makefile
target/linux/gemini/Makefile
target/linux/generic/patches-3.10/201-extra_optimization.patch
target/linux/generic/patches-3.3/201-extra_optimization.patch
target/linux/generic/patches-3.6/201-extra_optimization.patch
target/linux/generic/patches-3.8/201-extra_optimization.patch
target/linux/generic/patches-3.9/201-extra_optimization.patch
target/linux/imx23/Makefile
target/linux/lantiq/Makefile
target/linux/malta/be/target.mk
target/linux/malta/be64/target.mk
target/linux/malta/le/target.mk
target/linux/malta/le64/target.mk
target/linux/mcs814x/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/omap24xx/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/realview/Makefile
target/linux/sibyte/Makefile
target/linux/x86/rdc/target.mk

index db3094d729863f60b0ac2cb64a6644b13aabee2d..0ef2f1413d79b365df141646bd6742a7d550421a 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -847,6 +847,12 @@ menuconfig DEVEL
                  in the package directory, pointing to the .git tree that you want
                  to pull the source code from
 
                  in the package directory, pointing to the .git tree that you want
                  to pull the source code from
 
+       config EXTRA_OPTIMIZATION
+               string "Additional compiler options" if DEVEL
+               default "-fno-caller-saves"
+               help
+                 Extra Target-independent optimizations to use when building for the target.
+
 menuconfig TARGET_OPTIONS
        bool "Target Options"  if DEVEL
 
 menuconfig TARGET_OPTIONS
        bool "Target Options"  if DEVEL
 
index eeabb25f37812d2da9a7a900b0772cc18aea9784..b6d79fb20aa06c7138dfdf236d6869142f09e513 100644 (file)
@@ -191,17 +191,17 @@ ifeq ($(DUMP),1)
     # remove duplicates
     FEATURES:=$(sort $(FEATURES))
   endif
     # remove duplicates
     FEATURES:=$(sort $(FEATURES))
   endif
-  DEFAULT_CFLAGS_i386=-O2 -pipe -march=i486 -fno-caller-saves
-  DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64 -fno-caller-saves
-  DEFAULT_CFLAGS_m68k=-Os -pipe -mcfv4e -fno-caller-saves
-  DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -fno-caller-saves -mno-branch-likely
+  DEFAULT_CFLAGS_i386=-O2 -pipe -march=i486
+  DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64
+  DEFAULT_CFLAGS_m68k=-Os -pipe -mcfv4e
+  DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -mno-branch-likely
   DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
   DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
-  DEFAULT_CFLAGS_mips64=-Os -pipe -mips64 -mtune=mips64 -mabi=64 -fno-caller-saves
+  DEFAULT_CFLAGS_mips64=-Os -pipe -mips64 -mtune=mips64 -mabi=64
   DEFAULT_CFLAGS_mips64el=$(DEFAULT_CFLAGS_mips64)
   DEFAULT_CFLAGS_mips64el=$(DEFAULT_CFLAGS_mips64)
-  DEFAULT_CFLAGS_sparc=-Os -pipe -mcpu=ultrasparc -fno-caller-saves
-  DEFAULT_CFLAGS_arm=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
+  DEFAULT_CFLAGS_sparc=-Os -pipe -mcpu=ultrasparc
+  DEFAULT_CFLAGS_arm=-Os -pipe -march=armv5te -mtune=xscale
   DEFAULT_CFLAGS_armeb=$(DEFAULT_CFLAGS_arm)
   DEFAULT_CFLAGS_armeb=$(DEFAULT_CFLAGS_arm)
-  DEFAULT_CFLAGS=$(if $(DEFAULT_CFLAGS_$(ARCH)),$(DEFAULT_CFLAGS_$(ARCH)),-Os -pipe -fno-caller-saves)
+  DEFAULT_CFLAGS=$(if $(DEFAULT_CFLAGS_$(ARCH)),$(DEFAULT_CFLAGS_$(ARCH)),-Os -pipe)
 endif
 
 define BuildTargets/DumpCurrent
 endif
 
 define BuildTargets/DumpCurrent
index 5ed8000e05277a24cae1a544a60d6b2b44f8aeed..48be224858783088bb9339bf5284a0ac1dccb1e1 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -38,6 +38,7 @@ ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONF
 ARCH_PACKAGES:=$(call qstrip,$(CONFIG_TARGET_ARCH_PACKAGES))
 BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD))
 TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION))
 ARCH_PACKAGES:=$(call qstrip,$(CONFIG_TARGET_ARCH_PACKAGES))
 BOARD:=$(call qstrip,$(CONFIG_TARGET_BOARD))
 TARGET_OPTIMIZATION:=$(call qstrip,$(CONFIG_TARGET_OPTIMIZATION))
+export EXTRA_OPTIMIZATION:=$(call qstrip,$(CONFIG_EXTRA_OPTIMIZATION))
 TARGET_SUFFIX=$(call qstrip,$(CONFIG_TARGET_SUFFIX))
 BUILD_SUFFIX:=$(call qstrip,$(CONFIG_BUILD_SUFFIX))
 SUBDIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
 TARGET_SUFFIX=$(call qstrip,$(CONFIG_TARGET_SUFFIX))
 BUILD_SUFFIX:=$(call qstrip,$(CONFIG_BUILD_SUFFIX))
 SUBDIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
@@ -127,7 +128,7 @@ BUILD_LOG_DIR:=$(TOPDIR)/logs
 PKG_INFO_DIR := $(STAGING_DIR)/pkginfo
 
 TARGET_PATH:=$(STAGING_DIR_HOST)/bin:$(subst $(space),:,$(filter-out .,$(filter-out ./,$(subst :,$(space),$(PATH)))))
 PKG_INFO_DIR := $(STAGING_DIR)/pkginfo
 
 TARGET_PATH:=$(STAGING_DIR_HOST)/bin:$(subst $(space),:,$(filter-out .,$(filter-out ./,$(subst :,$(space),$(PATH)))))
-TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3)
+TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3) $(EXTRA_OPTIMIZATION)
 TARGET_CXXFLAGS = $(TARGET_CFLAGS)
 TARGET_ASFLAGS = $(TARGET_CFLAGS) $(TARGET_ASFLAGS_OVERRIDE)
 TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 TARGET_CXXFLAGS = $(TARGET_CFLAGS)
 TARGET_ASFLAGS = $(TARGET_CFLAGS) $(TARGET_ASFLAGS_OVERRIDE)
 TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
index 52cfc371ab7b686414c5f7164af5f5f35ae47c78..c123598e3b83455b32db18c9b739f576369e053f 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
 FEATURES:=squashfs targz mips16
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
 FEATURES:=squashfs targz mips16
-CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -fno-caller-saves -mno-branch-likely
+CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -mno-branch-likely
 SUBTARGETS:=generic nand
 
 LINUX_VERSION:=3.10.3
 SUBTARGETS:=generic nand
 
 LINUX_VERSION:=3.10.3
index ff93076f1d8eb9a3c6ebb39d9f56e68dd43cef1e..e9cc6d1c4912e16dd50772c098e0c0adbe2cbec1 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=at91
 MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
 FEATURES:=squashfs targz ext2 usb
 MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Atmel AT91
 FEATURES:=squashfs targz ext2 usb
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s
 
 LINUX_VERSION:=3.8.13
 
 
 LINUX_VERSION:=3.8.13
 
index a08679589a097e7b42c0ab1774588bda2470b1c9..bb691ddebc7e42f0e7ebc71498f0353501f0a64d 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=arm
 BOARD:=cns21xx
 BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 BOARD:=cns21xx
 BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
-CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
+CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526
 
 LINUX_VERSION:=3.8.13
 
 
 LINUX_VERSION:=3.8.13
 
index 96d6ab137c257227b0540029e38ee1bc54253b35..a169d0bbe9f53d401b8e27b5ee97f07a9c3268d2 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=arm
 BOARD:=cns3xxx
 BOARDNAME:=Cavium Networks Econa CNS3xxx
 FEATURES:=squashfs fpu gpio pcie usb usbgadget
 BOARD:=cns3xxx
 BOARDNAME:=Cavium Networks Econa CNS3xxx
 FEATURES:=squashfs fpu gpio pcie usb usbgadget
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
+CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.8.13
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.8.13
index 56799f9ba4d13109230376d7d4abc448daaa43fc..632b61c70ac5fa7cf7014bb5b5dfed5a0c46322b 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mipsel
 BOARD:=cobalt
 BOARDNAME:=Cobalt Microservers
 FEATURES:=targz pci ext4 display
 BOARD:=cobalt
 BOARDNAME:=Cobalt Microservers
 FEATURES:=targz pci ext4 display
-CFLAGS:=-O2 -pipe -mtune=r5000 -fno-caller-saves
+CFLAGS:=-O2 -pipe -mtune=r5000
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.3.8
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.3.8
index 21db716a797f4bc1e9847b8db3c375302be5ebf2..1cc08770cd2182e5dfcf2968ef38a9869944d07b 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=arm
 BOARD:=ep93xx
 BOARDNAME:=Cirrus Logic EP93xx
 FEATURES:=squashfs ext4 targz usb display sound
 BOARD:=ep93xx
 BOARDNAME:=Cirrus Logic EP93xx
 FEATURES:=squashfs ext4 targz usb display sound
-CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
+CFLAGS:=-Os -pipe -march=armv4t
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.8.13
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.8.13
index f0e802dba8584a25ab277ed9fc1a6328ff82c52f..e1586d138f4c12d69a2446c9e8f1e7599e9746c1 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
 FEATURES:=squashfs pci
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
 FEATURES:=squashfs pci
-CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
+CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.9.11
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.9.11
index 6af3d01ba225a7c4689852157e5d9a316fb9793d..ccb7fcfb3b2c5d41e992f6cb11e7eadcfff2e3b6 100644 (file)
@@ -5,10 +5,10 @@
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)
-+KBUILD_CFLAGS += -Os -fno-caller-saves $(call cc-disable-warning,maybe-uninitialized,)
++KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION) $(call cc-disable-warning,maybe-uninitialized,)
  else
 -KBUILD_CFLAGS += -O2
  else
 -KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
index e724891e4f5dacfe176e2f7227df48015ffb0627..213e6d12a17a1109e5180d2ec045c7c708fad344 100644 (file)
@@ -5,10 +5,10 @@
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os
-+KBUILD_CFLAGS += -Os -fno-caller-saves
++KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION)
  else
 -KBUILD_CFLAGS += -O2
  else
 -KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
index f255a01c1ad9b31fdc57599751865c9f8d01fe53..10b2c4dfa84262a575e6c2f97d250540b7b0707e 100644 (file)
@@ -5,10 +5,10 @@
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os
-+KBUILD_CFLAGS += -Os -fno-caller-saves
++KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION)
  else
 -KBUILD_CFLAGS += -O2
  else
 -KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
index 119655dfd32b5f36cb2ab2e910d6c487b828f185..a7d4bdcef335469b79ccf75a20a3fd82e5206e95 100644 (file)
@@ -5,10 +5,10 @@
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os
-+KBUILD_CFLAGS += -Os -fno-caller-saves
++KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION)
  else
 -KBUILD_CFLAGS += -O2
  else
 -KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
index bd8cc1226047ed9c68d47ac851809cc2ed7b30da..8354780aef264408db0b384433451d1940323fdb 100644 (file)
@@ -5,10 +5,10 @@
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os
-+KBUILD_CFLAGS += -Os -fno-caller-saves
++KBUILD_CFLAGS += -Os $(EXTRA_OPTIMIZATION)
  else
 -KBUILD_CFLAGS += -O2
  else
 -KBUILD_CFLAGS += -O2
-+KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch -fno-caller-saves
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch $(EXTRA_OPTIMIZATION)
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
  endif
  
  include $(srctree)/arch/$(SRCARCH)/Makefile
index b77988e78b31fb901758b19c877d4639e1e19c8d..f022cae8d5a401b23bedf2267b5547d50e963e92 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=arm
 BOARD:=imx23
 BOARDNAME:=Freescale i.MX23 series
 FEATURES:=ext4 rtc usb gpio
 BOARD:=imx23
 BOARDNAME:=Freescale i.MX23 series
 FEATURES:=ext4 rtc usb gpio
-CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 LINUX_VERSION:=3.10.3
 KERNELNAME:="zImage dtbs"
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 LINUX_VERSION:=3.10.3
 KERNELNAME:="zImage dtbs"
index 25fea540800f90f82a47070b8deb5d9f1b03b9e2..94b506d4eec539e5bde5949fd50d9c5826df9fb1 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS=xway ase falcon
 
 LINUX_VERSION:=3.8.13
 
 
 LINUX_VERSION:=3.8.13
 
-CFLAGS=-Os -pipe -mips32r2 -fno-caller-saves -mno-branch-likely
+CFLAGS=-Os -pipe -mips32r2 -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC
 
 define Target/Description
        Build firmware images for Lantiq SoC
index 90b655c8d2d2b043031098eb71f5303800341254..a4a00b7106ece5460edd8e06dcac8c2e76cb8887 100644 (file)
@@ -3,7 +3,7 @@ ARCH_PACKAGES:=malta_mips
 SUBTARGET:=be
 BOARDNAME:=Big Endian
 FEATURES:=ramdisk mips16
 SUBTARGET:=be
 BOARDNAME:=Big Endian
 FEATURES:=ramdisk mips16
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2
 
 define Target/Description
        Build BE firmware images for MIPS Malta CoreLV board running in
 
 define Target/Description
        Build BE firmware images for MIPS Malta CoreLV board running in
index 30804f4e1e534129f833ade3610094ba13749c3c..13c5d7e3b91e4b51f544e476f3b8c59bbae67ba5 100644 (file)
@@ -2,7 +2,7 @@ ARCH:=mips64
 ARCH_PACKAGES:=malta_mips64
 SUBTARGET:=be64
 BOARDNAME:=Big Endian (64-bits)
 ARCH_PACKAGES:=malta_mips64
 SUBTARGET:=be64
 BOARDNAME:=Big Endian (64-bits)
-CFLAGS:=-Os -pipe -mips64 -mtune=mips64 -fno-caller-saves
+CFLAGS:=-Os -pipe -mips64 -mtune=mips64
 FEATURES:=ramdisk
 
 define Target/Description
 FEATURES:=ramdisk
 
 define Target/Description
index 3b6e8953d014799552122f80796a4715ebe1ab61..e7c90e923589dbe947559328e91fa6b2000a9c85 100644 (file)
@@ -3,7 +3,7 @@ ARCH_PACKAGES:=malta_mipsel
 SUBTARGET:=le
 BOARDNAME:=Little Endian
 FEATURES:=ramdisk mips16
 SUBTARGET:=le
 BOARDNAME:=Little Endian
 FEATURES:=ramdisk mips16
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2
 
 define Target/Description
        Build LE firmware images for MIPS Malta CoreLV board running in
 
 define Target/Description
        Build LE firmware images for MIPS Malta CoreLV board running in
index bd5c63619e0df1c6311924b79315cb98a7959524..86fe90d446fa6f9bd0b5a8a043aac649c9ac8c37 100644 (file)
@@ -2,7 +2,7 @@ ARCH:=mips64el
 ARCH_PACKAGES:=malta_mipsel64
 SUBTARGET:=le64
 BOARDNAME:=Little Endian (64-bits)
 ARCH_PACKAGES:=malta_mipsel64
 SUBTARGET:=le64
 BOARDNAME:=Little Endian (64-bits)
-CFLAGS:=-Os -pipe -mips64 -mtune=mips64 -fno-caller-saves
+CFLAGS:=-Os -pipe -mips64 -mtune=mips64
 FEATURES:=ramdisk
 
 define Target/Description
 FEATURES:=ramdisk
 
 define Target/Description
index 55ae90c4c522b7bb3baab5a9a7ca7dceee09473a..dac17b8f90eb5dfb21b7c6525e34ce8a14362412 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=arm
 BOARD:=mcs814x
 BOARDNAME:=Moschip MCS814x
 FEATURES:=usb squashfs
 BOARD:=mcs814x
 BOARDNAME:=Moschip MCS814x
 FEATURES:=usb squashfs
-CFLAGS=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+CFLAGS=-Os -pipe -march=armv5te -mtune=arm926ej-s
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.3.8
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.3.8
index d3cf6a29503acbbe9dcdc62e469b3e2e80fdc612..7b07058944712e01ed33560493363f3a2845a153 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc52xx
 BOARDNAME:=Freescale MPC52xx
 ARCH:=powerpc
 BOARD:=mpc52xx
 BOARDNAME:=Freescale MPC52xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
+CFLAGS:=-Os -pipe -mcpu=603e
 FEATURES:=targz ext4
 
 LINUX_VERSION:=3.8.13
 FEATURES:=targz ext4
 
 LINUX_VERSION:=3.8.13
index 2a721dace07c9c485a3958ea2b042b1dc1c56257..1bb0d34bbcba455c15a4c7692ddf3e9172cefbb5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc83xx
 BOARDNAME:=Freescale MPC83xx
 ARCH:=powerpc
 BOARD:=mpc83xx
 BOARDNAME:=Freescale MPC83xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
+CFLAGS:=-Os -pipe -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
index 5a9e7ac6a140389283048713231b4f239dbe5833..c0dd6e216b0de653bb7bcc7fd2ceef6aa519bcd9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
+CFLAGS:=-Os -pipe -mcpu=8540
 FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
index a91b0d2d13eb2829fb501b557a35b604bd240be5..b3e54d31be0ea754e87007cf77f2c7e22a08155b 100644 (file)
@@ -18,7 +18,7 @@ define Target/Description
        TI OMAP-24xx
 endef
 
        TI OMAP-24xx
 endef
 
-CFLAGS:=-Os -pipe -march=armv6 -mtune=arm1136j-s -fno-caller-saves
+CFLAGS:=-Os -pipe -march=armv6 -mtune=arm1136j-s
 
 KERNELNAME:="zImage"
 
 
 KERNELNAME:="zImage"
 
index 14cb688293dfe35bb8517b1b8c9787a570a4b507..fa06466e89f603fd89f3c40adcc97f71f6a5031b 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
 SUBTARGETS:=generic harddisk
 BOARD:=orion
 BOARDNAME:=Marvell Orion
 SUBTARGETS:=generic harddisk
-CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
+CFLAGS=-Os -pipe -march=armv5te -mtune=xscale
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.3.8
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.3.8
index 39b074a5c73a82593a6546a10b57dbe89c0ef84f..3ae5ca9d1751f374d78f09343e548c1995af3a6b 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
+CFLAGS:=-Os -pipe -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.8.13
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.8.13
index 45512b55cc7079cf3eba55d3d3f4a835bd25c4d8..bd62efb2580ebf1992e9aa8e6cfa840d04c9d296 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs broken
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs broken
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+CFLAGS:=-Os -pipe -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.8.13
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.8.13
index d918b951c4c65261696762a918abe827c619327d..8d17d0ca324db24a471e0639dd35dde1cdb37de9 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt288x rt305x rt3883 mt7620a
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt288x rt305x rt3883 mt7620a
-CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
+CFLAGS:=-Os -pipe -mno-branch-likely
 FEATURES:=squashfs gpio
 
 LINUX_VERSION:=3.10.3
 FEATURES:=squashfs gpio
 
 LINUX_VERSION:=3.10.3
index 4668137c23d80a669276ac06f82c099a7480ec9d..4d6fa07acf6228e48f157a670b399bd5ff807fb9 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=arm
 BOARD:=realview
 BOARDNAME:=ARM Ltd. Realview board (qemu)
 FEATURES:=fpu ramdisk
 BOARD:=realview
 BOARDNAME:=ARM Ltd. Realview board (qemu)
 FEATURES:=fpu ramdisk
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
+CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.10.3
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.10.3
index fb27b4633dfe02d5a7333d49aaedf9b678a08be8..440cff3b859e5df0866b46c809345d52bbb6b2c6 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=sibyte
 BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=fpu ramdisk broken
 BOARD:=sibyte
 BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=fpu ramdisk broken
-CFLAGS:=-Os -pipe -march=sb1 -fno-caller-saves
+CFLAGS:=-Os -pipe -march=sb1
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.3.8
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 LINUX_VERSION:=3.3.8
index c9589452b006ef880bdfc8344758b612317f862f..e38f5e200667cf96614e15094fdd72be2205140f 100644 (file)
@@ -1,6 +1,6 @@
 BOARDNAME:=RDC R-321x
 FEATURES:=squashfs pci usb gpio pcmcia
 BOARDNAME:=RDC R-321x
 FEATURES:=squashfs pci usb gpio pcmcia
-CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -fno-caller-saves
+CFLAGS:=-Os -pipe -march=i486 -mtune=i486
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 DEFAULT_PACKAGES += kmod-llc kmod-stp kmod-bridge kmod-8021q \
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 DEFAULT_PACKAGES += kmod-llc kmod-stp kmod-bridge kmod-8021q \