add support for eglibc version 2.13
authorMirko Vogt <mirko@openwrt.org>
Sat, 18 Jun 2011 11:14:05 +0000 (11:14 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 18 Jun 2011 11:14:05 +0000 (11:14 +0000)
SVN-Revision: 27215

toolchain/eglibc/Config.in
toolchain/eglibc/Config.version
toolchain/eglibc/Makefile

index 1800d7c6dd0fbd5a25aca1aab816de509fa65687..2054e95b5dbc0cea6e0fbd715446401d6d58532a 100644 (file)
@@ -28,6 +28,10 @@ choice
                bool "eglibc 2.12"
                depends !GCC_VERSION_LLVM
 
+       config EGLIBC_VERSION_2_13
+               bool "eglibc 2.13"
+               depends !GCC_VERSION_LLVM
+
        config EGLIBC_VERSION_TRUNK
                bool "eglibc trunk"
 
@@ -44,6 +48,7 @@ config EGLIBC_REVISION
        default "10152" if EGLIBC_VERSION_2_10
        default "10454" if EGLIBC_VERSION_2_11
        default "10495" if EGLIBC_VERSION_2_12
+       default "13055" if EGLIBC_VERSION_2_13
        default "HEAD"  if EGLIBC_VERSION_TRUNK
        default ""
 
index 700c40924e2567d1ad1053b53d0d1ae4f78184d2..b3e2a15b0fae429065388557401ad86d3b5942e5 100644 (file)
@@ -8,4 +8,5 @@ config EGLIBC_VERSION
        default "2.10.2" if EGLIBC_VERSION_2_10
        default "2.11.1" if EGLIBC_VERSION_2_11
        default "2.12"   if EGLIBC_VERSION_2_12
+       default "2.13"   if EGLIBC_VERSION_2_13
        default "trunk"
index 5d34c95531523e524271783c00a60afea1608721..6be809745bc7520794e9f5d9401a1913613f42c4 100644 (file)
@@ -36,6 +36,9 @@ endif
 ifneq ($(CONFIG_EGLIBC_VERSION_2_12),)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_12
 endif
+ifneq ($(CONFIG_EGLIBC_VERSION_2_13),)
+  PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_13
+endif
 ifneq ($(CONFIG_EGLIBC_VERSION_TRUNK),)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/trunk
 endif