ramips: mt7621: fix WF-2881 for ubi split
authorJohn Crispin <john@openwrt.org>
Fri, 4 Mar 2016 08:33:17 +0000 (08:33 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 4 Mar 2016 08:33:17 +0000 (08:33 +0000)
This patch fix firmware split for WF-2881 which was previously manually partitioned.

Signed-off-by: YounJae Rho <luxflow@live.com>
SVN-Revision: 48908

target/linux/ramips/dts/WF-2881.dts
target/linux/ramips/image/Makefile

index aaafe5af827b616adf52779af01848a35b93a738..d33436c64a82987da2f4d368649931e8501f66fd 100644 (file)
                        read-only;
                };
 
-               firmware {
-                       label = "firmware";
-                       reg = <0x140000 0x6EC0000>;
-               };
-
                partition@140000 {
-                       label = "kernel";
-                       reg = <0x140000 0x200000>;
-               };
-
-               partition@340000 {
-                       label = "ubi";
-                       reg = <0x340000 0x6CC0000>;
+                       label = "firmware";
+                       reg = <0x140000 0x7E40000>;
                };
        };
 
index eb50cddeaf75b772729f1e76ddc1e1001432766a..f5e8e58ef93afee7a8830750371e5e54af9f2113 100644 (file)
@@ -1115,9 +1115,10 @@ define Device/wf-2881
   DTS := WF-2881
   BLOCKSIZE := 128KiB
   PAGESIZE := 2048
-  KERNEL_SIZE := 2097152
   FILESYSTEMS := squashfs
-  IMAGE/sysupgrade.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
+  IMAGE_SIZE := 132382720
+  KERNEL := $(KERNEL_DTB) | pad-offset 131072 64 | uImage lzma
+  IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
 endef
 
 define Device/ubnt-erx