images: allow generating .cpio.gz and/or .tar.gz archives whether ramdisk is selected...
authorNicolas Thill <nico@openwrt.org>
Wed, 28 Apr 2010 14:27:03 +0000 (14:27 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 28 Apr 2010 14:27:03 +0000 (14:27 +0000)
SVN-Revision: 21237

Config.in
include/image.mk

index ffe1147f44c70d028c4048edf705dd6e25ff9ee7..4746ba418599e06c7b4d552e3bfd4387336c4cdf 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -63,14 +63,12 @@ menu "Target Images"
        config TARGET_ROOTFS_TGZ
                bool "tgz"
                default y if USES_TGZ
-               depends !TARGET_ROOTFS_INITRAMFS
                help
                  Build a compressed tar archive of the the root filesystem
 
        config TARGET_ROOTFS_CPIOGZ
                bool "cpiogz"
                default y if USES_CPIOGZ
-               depends !TARGET_ROOTFS_INITRAMFS
                help
                  Build a compressed cpio archive of the the root filesystem
 
index 34453f460af57e9f1438274e0001a036b863c55a..8dc7e114b695958cc2289cfcbaad00a5b482f5ed 100644 (file)
@@ -95,17 +95,6 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
     endef
   endif
 
-  ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
-    define Image/mkfs/tgz
-               $(TAR) -zcf $(BIN_DIR)/$(IMG_PREFIX)-rootfs.tgz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
-    endef
-  endif
-
-  ifeq ($(CONFIG_TARGET_ROOTFS_CPIOGZ),y)
-    define Image/mkfs/cpiogz
-               ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
-    endef
-  endif
   ifeq ($(CONFIG_TARGET_ROOTFS_UBIFS),y)
     define Image/mkfs/ubifs
                $(CP) ./ubinize.cfg $(KDIR)
@@ -130,6 +119,18 @@ define Image/Checksum
 endef
 
 
+ifeq ($(CONFIG_TARGET_ROOTFS_CPIOGZ),y)
+  define Image/mkfs/cpiogz
+               ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
+  endef
+endif
+
+ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
+  define Image/mkfs/tgz
+               $(TAR) -zcf $(BIN_DIR)/$(IMG_PREFIX)-rootfs.tgz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
+  endef
+endif
+
 ifeq ($(CONFIG_TARGET_ROOTFS_EXT2FS),y)
   E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_FSPART)*1024)))