grub2: use the static lzma lib instead of the dynamic one
authorFelix Fietkau <nbd@openwrt.org>
Sun, 23 Sep 2012 10:38:06 +0000 (10:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 23 Sep 2012 10:38:06 +0000 (10:38 +0000)
SVN-Revision: 33526

package/grub2/Makefile

index 2a2244a7d6a09a1bd377602e00f82ada094df088..b606f54be181cfbc10de8a928e0ab7d30ce8ab95 100644 (file)
@@ -39,7 +39,8 @@ HOST_CONFIGURE_ARGS += \
        --disable-nls
 
 HOST_MAKE_FLAGS += \
-       TARGET_RANLIB=$(TARGET_RANLIB)
+       TARGET_RANLIB=$(TARGET_RANLIB) \
+       LIBLZMA=$(STAGING_DIR_HOST)/lib/liblzma.a
 
 define Host/Configure
        $(SED) 's,(RANLIB),(TARGET_RANLIB),' $(HOST_BUILD_DIR)/grub-core/Makefile.in