dnsmasq: fix handling ignore condition for dnssec
authorYousong Zhou <yszhou4tech@gmail.com>
Fri, 25 Sep 2020 02:28:19 +0000 (10:28 +0800)
committerYousong Zhou <yszhou4tech@gmail.com>
Fri, 25 Sep 2020 02:31:36 +0000 (10:31 +0800)
It should return false to indicate that the option should not be ignored

Fixes 064dc1e8 ("dnsmasq: abort when dnssec requested but not
available")

Reported-by: Sami Olmari <sami@olmari.fi>
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/files/dnsmasq.init

index b5f2e78fd2c2acb8af3d4f2c6b86e165ea1ceb95..fe68378f4823cc8d63882c24d2db5c4c1d98c93e 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=dnsmasq
 PKG_UPSTREAM_VERSION:=2.82
 PKG_VERSION:=$(subst test,~~test,$(subst rc,~rc,$(PKG_UPSTREAM_VERSION)))
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index d387c902855a8bb9167ba7d6f9e6a646861e4d67..0fa3074f92ddab4c711208e16f9e86c8b09afd52 100644 (file)
@@ -48,6 +48,7 @@ dnsmasq_ignore_opt() {
                                echo "dnsmasq: \"$opt\" requested, but dnssec support is not available" >&2
                                exit 1
                        fi
+                       return 1
                        ;;
                tftp-*)
                        [ -z "$dnsmasq_has_tftp" ] ;;