ar71xx: add support to TP-LINK TL-WA730RE v1
authorJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 14:45:25 +0000 (14:45 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 14:45:25 +0000 (14:45 +0000)
The TL-WA730RE seems to be almost identical to TL-WA701ND, just
that it comes without PoE and a stock-firmware claiming the device
to be a "Range Extender".

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 40972

target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index 7a285f21cb7fd4804ea15039d5fc0077274f05f6..2fbef9653e718614771f2cd11f968cbcb97d0903 100755 (executable)
@@ -106,6 +106,9 @@ tplink_board_detect() {
        "070100"*)
                model="TP-Link TL-WA701N/ND"
                ;;
+       "073000"*)
+               model="TP-Link TL-WA730RE"
+               ;;
        "074000"*)
                model="TP-Link TL-WR740N/ND"
                ;;
index aaf581b95c3f8a29ae772009ef5a4729a51881b0..5bd2cf68a0a1211aa5c1060aeb0a17381646775d 100644 (file)
@@ -139,6 +139,15 @@ define Profile/TLWA701/Description
 endef
 $(eval $(call Profile,TLWA701))
 
+define Profile/TLWA730RE
+       NAME:=TP-LINK TL-WA730RE
+       PACKAGES:=
+endef
+
+define Profile/TLWA730RE/Description
+       Package set optimized for the TP-LINK TL-WA730RE.
+endef
+$(eval $(call Profile,TLWA730RE))
 
 define Profile/TLWA750
        NAME:=TP-LINK TL-WA750RE
index 8da2095eda91f99cd14f5410ba7cc628c73dcd73..38f9e72a20e14df2c832d6222dc91447f1cefe4f 100644 (file)
@@ -1092,6 +1092,7 @@ $(eval $(call SingleProfile,TPLINK,64kraw,RNXN360RT,rnx-n360rt,TL-WR941ND,ttyS0,
 $(eval $(call SingleProfile,TPLINK,64kraw,TLMR3220V1,tl-mr3220-v1,TL-MR3220,ttyS0,115200,0x32200001,1,4M))
 $(eval $(call SingleProfile,TPLINK,64kraw,TLMR3420V1,tl-mr3420-v1,TL-MR3420,ttyS0,115200,0x34200001,1,4M))
 $(eval $(call SingleProfile,TPLINK,64kraw,TLWA701,tl-wa701n-v1,TL-WA901ND,ttyS0,115200,0x07010001,1,4M))
+$(eval $(call SingleProfile,TPLINK,64kraw,TLWA730REV1,tl-wa730rev1,TL-WA901ND,ttyS0,115200,0x07300001,1,4M))
 $(eval $(call SingleProfile,TPLINK,64kraw,TLWA7510NV1,tl-wa7510n,TL-WA7510N,ttyS0,115200,0x75100001,1,4M))
 $(eval $(call SingleProfile,TPLINK,64kraw,TLWA801NV1,tl-wa801nd-v1,TL-WA901ND,ttyS0,115200,0x08010001,1,4M))
 $(eval $(call SingleProfile,TPLINK,64kraw,TLWA830RV1,tl-wa830re-v1,TL-WA901ND,ttyS0,115200,0x08300010,1,4M))
@@ -1193,6 +1194,7 @@ $(eval $(call MultiProfile,TLMR11U,TLMR11UV1 TLMR11UV2))
 $(eval $(call MultiProfile,TLMR3040,TLMR3040V1 TLMR3040V2))
 $(eval $(call MultiProfile,TLMR3220,TLMR3220V1 TLMR3220V2))
 $(eval $(call MultiProfile,TLMR3420,TLMR3420V1 TLMR3420V2))
+$(eval $(call MultiProfile,TLWA730RE,TLWA730REV1))
 $(eval $(call MultiProfile,TLWA801,TLWA801NV1 TLWA801NV2))
 $(eval $(call MultiProfile,TLWA830,TLWA830RV1))
 $(eval $(call MultiProfile,TLWA901,TLWA901NV1 TLWA901NV2 TLWA901NV3))