make ModuleAutoLoad more readable
authorFlorian Fainelli <florian@openwrt.org>
Mon, 18 Oct 2010 06:58:11 +0000 (06:58 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 18 Oct 2010 06:58:11 +0000 (06:58 +0000)
When doing a build with tracing on, the expansion of ModuleAutoLoad can get a
little hairy.

Using intermediate variables to name the arguments makes tracing more readable.

One side effect is that if an argument is accidentally left out, we won't get
all of the parameters shifted one over thanks to quoting (done in AutoLoad).

Signed-of-by: Philip Prindeville <philipp@redfish-solutions.com>
SVN-Revision: 23513

include/kernel.mk

index 6ef4fd942d795ec265eb2ad410e0d20cc4b57f70..6795bd49fcb0ee760297c1bd78864bdc77bdd667 100644 (file)
@@ -67,16 +67,20 @@ define ModuleAutoLoad
        $(SH_FUNC) \
        export modules=; \
        add_module() { \
+               priority="$$$$$$$$1"; \
+               mods="$$$$$$$$2"; \
+               boot="$$$$$$$$3"; \
+               shift 3; \
                mkdir -p $(2)/etc/modules.d; \
                ( \
-                       [ "$$$$$$$$3" = "1" ] && { \
+                       [ "$$$$$$$$boot" = "1" ] && { \
                                echo '# May be required for rootfs' ; \
                        } ; \
-                       for mod in $$$$$$$$2; do \
-                               getvar mod; \
+                       for mod in $$$$$$$$mods; do \
+                               echo "$$$$$$$$mod"; \
                        done \
-               ) > $(2)/etc/modules.d/$$$$$$$$1-$(1); \
-               modules="$$$$$$$${modules:+$$$$$$$$modules }$$$$$$$$1-$(1)"; \
+               ) > $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
+               modules="$$$$$$$${modules:+$$$$$$$$modules }$$$$$$$$priority-$(1)"; \
        }; \
        $(3) \
        if [ -n "$$$$$$$$modules" ]; then \
@@ -156,7 +160,7 @@ $(call KernelPackage/$(1)/config)
 endef
 
 define AutoLoad
-  add_module $(1) "$(2)" $(3);
+  add_module "$(1)" "$(2)" "$(3)";
 endef
 
 ifdef DUMP