brcm47xx: build b44 as a module
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 3 Jan 2013 02:00:25 +0000 (02:00 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 3 Jan 2013 02:00:25 +0000 (02:00 +0000)
SVN-Revision: 34994

package/kernel/modules/netdevices.mk
target/linux/brcm47xx/base-files/lib/preinit/05_init_interfaces_brcm
target/linux/brcm47xx/config-3.6
target/linux/brcm47xx/profiles/100-Broadcom-b43.mk
target/linux/brcm47xx/profiles/101-Broadcom-wl.mk
target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk
target/linux/brcm47xx/profiles/105-Broadcom-none.mk
target/linux/brcm47xx/profiles/PS-1208MFG.mk
target/linux/brcm47xx/profiles/WGT634U.mk
target/linux/brcm47xx/profiles/WL500GPv1-ATH.mk
target/linux/brcm47xx/profiles/WRTSL54GS.mk

index bab3d7094779eb31b0e3e8e868af00ad5fa49eec..83d7c5f56ec2bd97a79bc7e075c347045fe79a6e 100644 (file)
@@ -419,7 +419,7 @@ $(eval $(call KernelPackage,e1000e))
 define KernelPackage/b44
   TITLE:=Broadcom 44xx driver
   KCONFIG:=CONFIG_B44
-  DEPENDS:=@PCI_SUPPORT +kmod-ssb
+  DEPENDS:=@PCI_SUPPORT +!TARGET_brcm47xx:kmod-ssb
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   FILES:=$(LINUX_DIR)/drivers/net/ethernet/broadcom/b44.ko
   AUTOLOAD:=$(call AutoLoad,50,b44)
index 3ca8456ffb926b864e173e310d318579179a378d..d4a3b682c859f487bef53ee803be92c4f2093ffb 100644 (file)
@@ -6,6 +6,7 @@ set_preinit_iface() {
        insmod diag
        insmod hwmon
        insmod tg3
+       insmod b44
 
        # hardware specific overrides
        case "$(cat /proc/diag/model)" in
index 421590c1492264d534f9fb76d2e93a200c989a0d..ae56ccf4dcc7cd0ef76bc505e02b90d66f203bae 100644 (file)
@@ -7,10 +7,6 @@ CONFIG_ARCH_REQUIRE_GPIOLIB=y
 CONFIG_ARCH_SUSPEND_POSSIBLE=y
 CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
 # CONFIG_ARPD is not set
-CONFIG_B44=y
-CONFIG_B44_PCI=y
-CONFIG_B44_PCICORE_AUTOSELECT=y
-CONFIG_B44_PCI_AUTOSELECT=y
 CONFIG_BCM47XX=y
 CONFIG_BCM47XX_BCMA=y
 CONFIG_BCM47XX_SSB=y
index 7880ce80f6d688ed48c7e7a3e075ce0693913d11..54e3909b686c425a3742835c9c136c28140bf39d 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom-b43
   NAME:=Broadcom BCM43xx WiFi (b43, default)
-  PACKAGES:=kmod-b43 kmod-b43legacy
+  PACKAGES:=kmod-b44 kmod-b43 kmod-b43legacy
 endef
 
 define Profile/Broadcom-b43/Description
index 1464b7e15f440ba4d9e3ce95c1f7a5d88687f970..bad38de671f5d0d64bd07c18978fb8aaa144ba79 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom-wl
   NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
-  PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas
+  PACKAGES:=-wpad-mini kmod-b44 kmod-brcm-wl wlc nas
 endef
 
 define Profile/Broadcom-wl/Description
index 32baa089aa33aed454ba1cd12fb59f30323c9ce7..56a505a90e55ce53d3f809e986d4f5e12e2a9e10 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom-ath5k
   NAME:=Atheros WiFi (ath5k)
-  PACKAGES:=kmod-ath5k
+  PACKAGES:=kmod-b44 kmod-ath5k
 endef
 
 define Profile/Atheros/Description
index 04ad25dc677e9549e97a13ee660c9bef6a8d6323..d04813692aab3a0ecdb3e3a85d9ee3e5412010b0 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom-none
   NAME:=No WiFi
-  PACKAGES:=-wpad-mini
+  PACKAGES:=-wpad-mini kmod-b44
 endef
 
 define Profile/None/Description
index 5d7388ba1b877ef7fd1963cb4a88e013ba195bf8..8d8aa687b60ed5fde0e0735d61a537e461745a55 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Ps1208mfg
   NAME:=Edimax PS-1208MFG
-  PACKAGES:=-firewall -dropbear -dnsmasq -mtd -ppp -wpad-mini block-mount kmod-usb-storage kmod-usb2 kmod-usb-ohci -iptables -kmod-switch kmod-fs-ext4 block-extroot
+  PACKAGES:=-firewall -dropbear -dnsmasq -mtd -ppp -wpad-mini kmod-b44 block-mount kmod-usb-storage kmod-usb2 kmod-usb-ohci -iptables -kmod-switch kmod-fs-ext4 block-extroot
 endef
 
 define Profile/Ps1208mfg/Description
index 81f59a729447db46105fceed66fa0569e80c7bd6..689b673f3e7772fecbf3595fbed3bff4e3b5dc99 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/WGT634U
   NAME:=Netgear WGT634U
-  PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb2 kmod-ocf kmod-crypto-ocf-ubsec-ssb
+  PACKAGES:=kmod-b44 kmod-ath5k kmod-usb-core kmod-usb2 kmod-ocf kmod-crypto-ocf-ubsec-ssb
 endef
 
 define Profile/WGT634U/Description
index 4d50db34744e58c84149d5ec53005f7c2244767c..3cdd8a0b33d7dcdb7697950fd64fc1c62849a212 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/WL500GPv1
   NAME:=ASUS WL-500g Premium v1 (Atheros WiFi using ath5k)
-  PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb-uhci kmod-usb2
+  PACKAGES:=kmod-b44 kmod-ath5k kmod-usb-core kmod-usb-uhci kmod-usb2
 endef
 
 define Profile/WL500GPv1/Description
index 0e53c7d138dc8d1409ad743f401e231fe8cb3419..68d9a17fe86cb8aeab008baf10b3b5da60802a84 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/WRTSL54GS
   NAME:=Linksys WRTSL54GS
-  PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage kmod-scsi-core kmod-fs-ext3 e2fsprogs kmod-b43
+  PACKAGES:=kmod-b44 kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage kmod-scsi-core kmod-fs-ext3 e2fsprogs kmod-b43
 endef
 
 define Profile/WRTSL54GS/Description