package/libs/libnl: Update to 3.2.28
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Sat, 8 Oct 2016 18:58:41 +0000 (13:58 -0500)
committerJohn Crispin <john@phrozen.org>
Sat, 15 Oct 2016 09:36:50 +0000 (11:36 +0200)
Update to 3.2.28
Remove patch as its in upstream

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
package/libs/libnl/Makefile
package/libs/libnl/patches/001-fix-poll-h-include-warning-on-musl.h [deleted file]

index b8e90675383d8bc24b2c3e9e17b86733a75ac297..86ef044a1706be2974be6839d5b5870b8cfc316d 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnl
-PKG_VERSION:=3.2.21
+PKG_VERSION:=3.2.28
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.infradead.org/~tgr/libnl/files/
-PKG_MD5SUM:=6fe7136558a9071e70673dcda38545b3
+PKG_SOURCE_URL:=https://github.com/thom311/libnl/releases/download/libnl3_2_28
+PKG_MD5SUM:=cd608992c656e8f6e3ab6c1391b162a5a51c49336b9219f7f390e61fc5437c41
 PKG_LICENSE:=LGPL-2.1
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/package/libs/libnl/patches/001-fix-poll-h-include-warning-on-musl.h b/package/libs/libnl/patches/001-fix-poll-h-include-warning-on-musl.h
deleted file mode 100644 (file)
index ec9d4bc..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/include/netlink/netlink.h b/include/netlink/netlink.h
-index 5f68548..3bf3ed5 100644
---- a/include/netlink/netlink.h
-+++ b/include/netlink/netlink.h
-@@ -16,7 +16,7 @@
- #include <stdint.h>
- #include <string.h>
- #include <stdlib.h>
--#include <sys/poll.h>
-+#include <poll.h>
- #include <sys/socket.h>
- #include <sys/types.h>
- #include <sys/time.h>