ncurses: install ncurses5-config and ncursesw5-config (#9044)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 21 Mar 2011 06:45:20 +0000 (06:45 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 21 Mar 2011 06:45:20 +0000 (06:45 +0000)
SVN-Revision: 26255

package/ncurses/Makefile

index 6b2f7b63001fbe966168e6e07a39d3b2ca18faad..69a204136966da276a55a185bf9aa13242ff74f3 100644 (file)
@@ -126,6 +126,12 @@ define Build/InstallDev
 
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ncurses,panel,menu,form}w.{a,so*} $(1)/usr/lib/
+
+       $(INSTALL_DIR) $(1)/usr/bin $(2)/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw5-config $(2)/bin/
+       $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+       $(2)/bin/ncursesw5-config
+       ln -sf $(STAGING_DIR)/host/bin/ncursesw5-config $(1)/usr/bin/ncursesw5-config
 endef
 else
 define Build/InstallDev
@@ -134,6 +140,12 @@ define Build/InstallDev
 
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{curses,ncurses,panel,menu,form}.{a,so*} $(1)/usr/lib/
+
+       $(INSTALL_DIR) $(1)/usr/bin $(2)/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncurses5-config $(2)/bin/
+       $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/ncurses5-config
+       ln -sf $(STAGING_DIR)/host/bin/ncurses5-config $(1)/usr/bin/ncurses5-config
 endef
 endif