omap24xx: Add config option for n810 bluetooth driver
authorMichael Büsch <mb@bu3sch.de>
Mon, 7 Mar 2011 16:14:10 +0000 (16:14 +0000)
committerMichael Büsch <mb@bu3sch.de>
Mon, 7 Mar 2011 16:14:10 +0000 (16:14 +0000)
SVN-Revision: 25934

package/kernel/modules/other.mk

index 0ecc7b37861393594ddbdce57918f3c55ad31836..aba1c6b7d19f0947d4377d131f9918d31381e7da 100644 (file)
@@ -55,6 +55,22 @@ endef
 $(eval $(call KernelPackage,bluetooth))
 
 
+define KernelPackage/bluetooth-hci-h4p
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=HCI driver with H4 Nokia extensions
+  DEPENDS:=@TARGET_omap24xx +kmod-bluetooth
+  KCONFIG:=CONFIG_BT_HCIH4P
+  FILES:=$(LINUX_DIR)/drivers/bluetooth/hci_h4p/hci_h4p.ko
+  AUTOLOAD:=$(call AutoLoad,91,hci_h4p)
+endef
+
+define KernelPackage/bluetooth-hci-h4p/description
+  HCI driver with H4 Nokia extensions
+endef
+
+$(eval $(call KernelPackage,bluetooth-hci-h4p))
+
+
 define KernelPackage/cpu-msr
   SUBMENU:=$(OTHER_MENU)
   TITLE:=x86 CPU MSR support