package/kernel: kmod-hid: can't mix and match DEPENDS:= and $(call SetDepends/...)
authorJonas Gorski <jogo@openwrt.org>
Sun, 14 Aug 2011 23:36:45 +0000 (23:36 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 14 Aug 2011 23:36:45 +0000 (23:36 +0000)
Since the SetDepends macro does a:

  DEPENDS:= ...

it can't be used after setting DEPENDS:= explicitly, or it will clobber the previous value.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
SVN-Revision: 27983

package/kernel/modules/other.mk

index e67c41b72e8a7c5b63fbb86019c239060faaa6f7..1e252e3746077bf1238ed53f10b567c8af4b3f10 100644 (file)
@@ -252,12 +252,11 @@ $(eval $(call KernelPackage,gpio-nxp-74hc164))
 define KernelPackage/hid
   SUBMENU:=$(OTHER_MENU)
   TITLE:=HID Devices
-  DEPENDS:=+kmod-input-evdev
   KCONFIG:=CONFIG_HID
   FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
   AUTOLOAD:=$(call AutoLoad,61,hid)
   $(call SetDepends/hid)
-  $(call AddDepends/input)
+  $(call AddDepends/input,+kmod-input-evdev)
 endef
 
 define KernelPackage/hid/description