build: image: fix build breakage of some images
authorPetr Štetiar <ynezz@true.cz>
Tue, 5 Nov 2019 22:57:37 +0000 (23:57 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 30 Jun 2020 20:12:50 +0000 (22:12 +0200)
Commit 881ed09ee6e2 ("build: create JSON files containing image info")
has removed the crucial empty new line from the image copy step
resulting in the following errors during make function expansion:

 GZ_SUFFIX :=
 bash: GZ_SUFFIX: command not found
 Makefile:86: recipe for target 'openwrt-ath79-generic-tplink_archer-c7-v5-squashfs-sysupgrade.bin' failed

Fixes: 881ed09ee6e2 ("build: create JSON files containing image info")
Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit 0fb23d67f00a18c3f9e712ca97cfc34b38071f4a)

include/image.mk

index 2eedb43753ed2823cb364aa8b70257e11f57b4a5..1e0177c439860179a6a3088dc3c868a5f0bdff13 100644 (file)
@@ -538,6 +538,7 @@ define Device/Build/image
                SUPPORTED_DEVICES="$(SUPPORTED_DEVICES)" \
                $(TOPDIR)/scripts/json_add_image_info.py \
        )
+
 endef
 
 define Device/Build/artifact